gnu: gemma: Update to 0.98.3.
[jackhill/guix/guix.git] / gnu / packages / sssd.scm
index 2afef03..b2b5da9 100644 (file)
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages glib)
-  #:use-module (gnu packages gnuzilla)
+  #:use-module (gnu packages kerberos)
   #:use-module (gnu packages libunistring)
   #:use-module (gnu packages linux)
-  #:use-module (gnu packages kerberos)
+  #:use-module (gnu packages nss)
   #:use-module (gnu packages openldap)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages pcre)
 (define-public ding-libs
   (package
     (name "ding-libs")
-    (version "0.6.0")
+    (version "0.6.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://releases.pagure.org/SSSD/ding-libs/"
                                   "ding-libs-" version ".tar.gz"))
               (sha256
                (base32
-                "1bczkvq7cblp75kqn6r2d7j5x7brfw6wxirzc6d2rkyb80gj2jkn"))))
+                "1h97mx2jdv4caiz4r7y8rxfsq78fx0k4jjnfp7x2s7xqvqks66d3"))))
     (build-system gnu-build-system)
     (home-page "https://pagure.io/SSSD/ding-libs/")
     (synopsis "Libraries for SSSD")
@@ -80,14 +82,16 @@ fundamental object types for C.")
 (define-public sssd
   (package
     (name "sssd")
-    (version "1.15.2")
+    (version "1.16.5")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://releases.pagure.org/SSSD/sssd/"
+              (uri (string-append "https://releases.pagure.org/SSSD/sssd/"
                                   "sssd-" version ".tar.gz"))
               (sha256
                (base32
-                "0r6j28f7vjb1aw65gkw4nz2l3jy605h7wsr1k815hynp2jrzrmac"))))
+                "1h6hwibaf3xa2w6qpzjiiywmfj6zkgbz4r2isf3gd0xm6vq7n6if"))
+              (patches (search-patches "sssd-fix-samba.patch"
+                                       "sssd-system-directories.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags
@@ -100,7 +104,10 @@ fundamental object types for C.")
              ;; online DTDs.
              "XMLLINT_FLAGS = --catalogs --nonet --noent --xinclude --noout")
        #:configure-flags
-       (list "--disable-cifs-idmap-plugin"
+       (list "--localstatedir=/var" ;for /var/lib/sss, /var/run/sssd.pid, etc.
+             "--sysconfdir=/etc"    ;/etc/sssd
+
+             "--disable-cifs-idmap-plugin"
              "--without-nfsv4-idmapd-plugin"
              "--without-python2-bindings"
              "--without-python3-bindings"
@@ -157,17 +164,19 @@ fundamental object types for C.")
        ("tdb" ,tdb)
        ("tevent" ,tevent)))
     (native-inputs
-     `(("check" ,check)
+     `(("check" ,check-0.14)
        ("docbook-xsl" ,docbook-xsl)
        ("docbook-xml" ,docbook-xml)
+       ("libxml2" ,libxml2)             ; for xmllint
        ("libxslt" ,libxslt)
-       ("pkg-config" ,pkg-config)))
+       ("pkg-config" ,pkg-config)
+       ("util-linux" ,util-linux "lib"))) ;for uuid.h, reqired for KCM
     (home-page "https://pagure.io/SSSD/sssd/")
     (synopsis "System security services daemon")
     (description "SSSD is a system daemon.  Its primary function is to provide
 access to identity and authentication remote resource through a common
 framework that can provide caching and offline support to the system.  It
-provides PAM and NSS modules, and in the future will D-BUS based interfaces
-for extended user information.  It also provides a better database to store
-local users as well as extended user data.")
+provides PAM and NSS modules, and in the future will support D-BUS based
+interfaces for extended user information.  It also provides a better database
+to store local users as well as extended user data.")
     (license license:gpl3+)))