gnu: webkitgtk: Update to 2.28.2.
[jackhill/guix/guix.git] / gnu / packages / cyrus-sasl.scm
index 3c6a878..f84136e 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;;
@@ -20,8 +20,8 @@
 
 (define-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages)
-  #:use-module (gnu packages databases)
-  #:use-module (gnu packages mit-krb5)
+  #:use-module (gnu packages dbm)
+  #:use-module (gnu packages kerberos)
   #:use-module (gnu packages tls)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
@@ -31,7 +31,7 @@
 (define-public cyrus-sasl
   (package
    (name "cyrus-sasl")
-   (version "2.1.26")
+   (version "2.1.27")
    (source (origin
             (method url-fetch)
             (uri (list (string-append
                        (string-append
                         "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
                         version ".tar.gz")))
-            (patches (search-patches "cyrus-sasl-CVE-2013-4122.patch"))
             (sha256 (base32
-                     "1hvvbcsg21nlncbgs0cgn3iwlnb3vannzwsp6rwvnn9ba4v53g4g"))))
+                     "1m85zcpgfdhm43cavpdkhb1s2zq1b31472hq1w1gs3xh94anp1i6"))))
    (build-system gnu-build-system)
    (inputs `(("gdbm" ,gdbm)
-             ("mit-krb5" ,mit-krb5)
              ("openssl" ,openssl)))
+   (propagated-inputs
+    `(;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
+      ("mit-krb5" ,mit-krb5)))
    (arguments
     '(#:configure-flags (list (string-append "--with-plugindir="
                                              (assoc-ref %outputs "out")
@@ -65,4 +66,4 @@ library makes supporting various SASL mechanisms easy for both client and
 server writers.")
    (license (license:non-copyleft "file://COPYING"
                                   "See COPYING in the distribution."))
-   (home-page "http://cyrusimap.web.cmu.edu")))
+   (home-page "https://cyrusimap.org/sasl/")))