gnu: ganeti: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / synergy.scm
index 9de3ee5..1f8f8f3 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015, 2016, 2020 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 (define-public synergy
   (package
     (name "synergy")
-    (version "1.10.1")
+    (version "1.11.1")
     (source
      (origin
       (method git-fetch)
       (uri (git-reference
-            (url "https://github.com/symless/synergy-core.git")
+            (url "https://github.com/symless/synergy-core")
             (commit (string-append "v" version "-stable"))))
       (file-name (git-file-name name version))
       (sha256
        (base32
-        "112w2xrp04cysd14xk1ax7cllqpcki0pyica4ivrdngr5qw0r9hp"))
+        "0dn0h3mdqy0mbg4yyhsh4rhvvsssqlknnln3naplc97my10lk2a0"))
       (modules '((guix build utils)))
       (snippet
        ;; Remove unnecessary bundled source and binaries
            (lambda* (#:key inputs #:allow-other-keys)
              (setenv "CPLUS_INCLUDE_PATH"
                      (string-append (assoc-ref inputs "avahi")
-                                    "/include/avahi-compat-libdns_sd"))
-             ;; See https://github.com/symless/synergy-core/pull/6359/
-             (substitute* "src/gui/src/ScreenSetupView.cpp"
-               (("#include <QtGui>" m)
-                (string-append m "\n#include <QHeaderView>")))
-             (substitute* "src/gui/src/ActionDialog.cpp"
-               (("#include <QtGui>" m)
-                (string-append m "\n#include <QButtonGroup>")))
-             #t)))))
+                                    "/include/avahi-compat-libdns_sd:"
+                                    (or (getenv "CPLUS_INCLUDE_PATH") "")))
+             #t))
+         (add-after 'install 'patch-desktop
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (substitute* (string-append out "/share/applications/synergy.desktop")
+                 (("/usr") out))
+               #t))))))
+    (native-inputs
+     `(("qttools" ,qttools)))           ; for Qt5LinguistTools
     (inputs
      `(("avahi" ,avahi)
        ("python"  ,python-wrapper)
@@ -80,7 +82,6 @@
        ("libxi"   ,libxi)
        ("libx11"  ,libx11)
        ("libxtst" ,libxtst)
-       ("xinput"  ,xinput)
        ("qtbase" ,qtbase)))
     (home-page "https://symless.com/synergy")
     (synopsis "Mouse and keyboard sharing utility")