gnu: gourmet: Fix runtime failure and enhance plugin.
[jackhill/guix/guix.git] / gnu / packages / nutrition.scm
index 9e0430b..0e03253 100644 (file)
@@ -23,6 +23,7 @@
   #:use-module (guix download)
   #:use-module (guix build-system python)
   #:use-module (gnu packages)
+  #:use-module (gnu packages databases)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages image)
     (inputs
      `(("pygtk"             ,python2-pygtk)
        ("sqlalchemy"        ,python2-sqlalchemy)
+       ("python-lxml"       ,python2-lxml)
        ("python-pillow"     ,python2-pillow)
        ("elib.intl"         ,python2-elib.intl)))
     (arguments
      `(#:python ,python-2               ;exception and print syntax
-       #:tests? #f))                    ;tests look bitrotted
+       #:tests? #f                      ;tests look bitrotted
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'install
+           (lambda* (#:key make-flags #:allow-other-keys)
+             (zero? (system* "python" "setup.py" "install" "--prefix"
+                             (assoc-ref %outputs "out"))))))))
     (home-page "http://thinkle.github.io/gourmet/")
     (synopsis "Recipe organizer")
     (description