gnu: Add rust-proc-macro-hack-impl-0.4.
[jackhill/guix/guix.git] / gnu / packages / tbb.scm
index b8f3242..f04385c 100644 (file)
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016 ng0 <ng0@n0.is>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public tbb
   (package
     (name "tbb")
-    (version "2019_U6")
+    (version "2020.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/01org/tbb")
-                    (commit version)))
+                    (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1zbf06l659vq6s5wp3ln96ycwcd42caffan5vilqvqyxqvjljyic"))
+                "1vrh1mr9jmj46as9y8j5q1hpvihzd1iq4jr1y4x9a19dw8b7yk56"))
               (modules '((guix build utils)))
               (snippet
                '(begin
                   (substitute* "build/common.inc"
                     (("export tbb_build_prefix.+$")
                      "export tbb_build_prefix?=guix\n"))
+
+                  ;; Don't capture the build time and kernel version.
+                  (substitute* "build/version_info_linux.sh"
+                    (("uname -srv") "uname -s")
+                    (("`date -u`") "01 Jan 1970"))
+
+                  (substitute* "build/linux.inc"
+                    (("os_kernel_version:=.*")
+                     "os_kernel_version:=5\n")
+                    (("os_version:=.*")
+                     "os_version:=1\n"))
                   #t))))
     (outputs '("out" "doc"))
     (build-system gnu-build-system)