gnu: facter: Update to 4.0.33.
[jackhill/guix/guix.git] / gnu / packages / connman.scm
index 4369e06..5f17a0e 100644 (file)
@@ -1,9 +1,9 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public connman
   (package
     (name "connman")
-    (version "1.36")
+    (version "1.38")
     (source
       (origin
         (method url-fetch)
         (uri (string-append "mirror://kernel.org/linux/network/connman/"
                             "connman-" version ".tar.xz"))
     (sha256
-     (base32
-      "0x00dq5c2frz06md3g5y0jh5kbcj2hrfl5qjcqga8gs4ri0xp2f7"))))
+     (base32 "0awkqigvhwwxiapw0x6yd4whl465ka8a4al0v2pcqy9ggjlsqc6b"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
        (list "--enable-nmcompat"
-             "--enable-polkit"
+             "--enable-polkit" ; Polkit doesn't need to be present at build time.
              "--enable-openconnect"
              "--enable-openvpn"
              "--enable-vpnc"
-             "--enable-pptp"
              "--enable-l2tp"
-             ;; location for daemon state files and internal configuration
-             ;; needs to be writeable
              "--localstatedir=/var"
              (string-append
               "--with-dbusconfdir=" (assoc-ref %outputs "out") "/etc")
               "--with-dbusdatadir=" (assoc-ref %outputs "out") "/share"))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
-       ("python" ,python-2)))
+       ("python" ,python-wrapper)))
     (inputs
      `(("dbus" ,dbus)
        ("glib" ,glib)
        ("gnutls" ,gnutls)
        ("iptables" ,iptables)
-       ("polkit" ,polkit)        ;so connman can be used by unprivileged users
+       ("libmnl" ,libmnl)
        ("readline" ,readline)
        ;; These inputs are needed for connman to include the interface to
        ;; these technologies so IF they are installed they can be used.
@@ -87,7 +83,8 @@
        ("openvpn" ,openvpn)
        ("ppp" ,ppp)
        ("vpnc" ,vpnc)
-       ("wpa-supplicant" ,wpa-supplicant)))
+       ("wpa-supplicant" ,wpa-supplicant)
+       ("xl2tpd" ,xl2tpd)))
     (home-page "https://01.org/connman")
     (synopsis "Connection management daemon")
     (description "Connman provides a daemon for managing Internet connections.
@@ -129,9 +126,9 @@ sharing) to clients via USB, ethernet, WiFi, cellular and Bluetooth.")
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs
      `(("efl" ,efl)
-       ("python-2" ,python-2)
-       ("python2-dbus" ,python2-dbus)
-       ("python2-efl" ,python2-efl)))
+       ("python" ,python-wrapper)
+       ("python-dbus" ,python-dbus)
+       ("python-efl" ,python-efl)))
     (home-page "https://www.enlightenment.org")
     (synopsis "Connman User Interface written using the EFL")
     (description
@@ -141,7 +138,7 @@ sharing) to clients via USB, ethernet, WiFi, cellular and Bluetooth.")
 (define-public cmst
   (package
     (name "cmst")
-    (version "2017.09.19")
+    (version "2019.01.13")
     (source
      (origin
        (method url-fetch)
@@ -149,7 +146,7 @@ sharing) to clients via USB, ethernet, WiFi, cellular and Bluetooth.")
              "https://github.com/andrew-bibb/cmst/releases/download/cmst-"
              version "/cmst-" version ".tar.xz"))
        (sha256
-        (base32 "0dh4639n3l8a19svaagib41hdq5q7x70bnc28dmnwy4jflf38yrm"))))
+        (base32 "1cn6xz2rpkf5kx5d6p2x2lh85zppjacp59l6gj3n6x12p90al1vl"))))
     (inputs
      `(("qtbase" ,qtbase)))
     (native-inputs
@@ -163,13 +160,22 @@ sharing) to clients via USB, ethernet, WiFi, cellular and Bluetooth.")
              (invoke "qmake"
                      (string-append "PREFIX="
                                     (assoc-ref outputs "out")))))
-         (add-before 'install 'fix-Makefiles
+         (add-before 'build 'fix-Makefiles
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
                (substitute* (find-files "." "Makefile")
                  (("INSTALL_ROOT)")
                   (string-append "INSTALL_ROOT)" out))
-                 (("/usr/bin") "/bin"))))))))
+                 (("/usr") ""))
+               (substitute* '("apps/cmstapp/cmstapp.pro"
+                              "apps/cmstapp/code/control_box/controlbox.cpp"
+                              "apps/rootapp/rootapp.pro"
+                              "apps/rootapp/system/org.cmst.roothelper.service"
+                              "cmst.pri"
+                              "cmst.pro")
+                 (("/usr") out)
+                 (("/etc") (string-append out "/etc")))
+               #t))))))
     (home-page "https://github.com/andrew-bibb/cmst")
     (synopsis "Qt frontend for Connman")
     (description