gnu: dealii: Update to 8.5.0.
[jackhill/guix/guix.git] / gnu / packages / cyrus-sasl.scm
index 0c92cc3..b48505e 100644 (file)
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 
 (define-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages)
-  #:use-module (gnu packages gdbm)
-  #:use-module (gnu packages mit-krb5)
-  #:use-module (gnu packages openssl)
-  #:use-module ((guix licenses)
-                #:renamer (symbol-prefix-proc 'license:))
+  #:use-module (gnu packages databases)
+  #:use-module (gnu packages kerberos)
+  #:use-module (gnu packages tls)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu))
    (source (origin
             (method url-fetch)
             (uri (list (string-append
-                        "http://cyrusimap.org/releases/cyrus-sasl-"
+                        "https://cyrusimap.org/releases/cyrus-sasl-"
                         version ".tar.gz")
                        (string-append
                         "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
                         version ".tar.gz")))
+            (patches (search-patches "cyrus-sasl-CVE-2013-4122.patch"))
             (sha256 (base32
                      "1hvvbcsg21nlncbgs0cgn3iwlnb3vannzwsp6rwvnn9ba4v53g4g"))))
    (build-system gnu-build-system)
       ;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
       ;; fail with EEXIST when building things in parallel.
       #:parallel-build? #f))
-   (synopsis "Cyrus SASL, an implementation of the Simple Authentication Security Layer framework")
+   (synopsis "Simple Authentication Security Layer implementation")
    (description
     "SASL (Simple Authentication Security Layer) is an Internet
-standards-track method for remote computers to authenticate. The Cyrus SASL
+standards-track method for remote computers to authenticate.  The Cyrus SASL
 library makes supporting various SASL mechanisms easy for both client and
 server writers.")
-   (license (license:bsd-style "file://COPYING"
-                       "See COPYING in the distribution."))
-   (home-page "http://cyrusimap.web.cmu.edu/index.php")))
+   (license (license:non-copyleft "file://COPYING"
+                                  "See COPYING in the distribution."))
+   (home-page "http://cyrusimap.web.cmu.edu")))