gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / prolog.scm
index bf992f6..a5c57cd 100644 (file)
@@ -86,17 +86,17 @@ manner.  It also features an interactive interpreter.")
 (define-public swi-prolog
   (package
     (name "swi-prolog")
-    (version "8.1.21")
+    (version "8.3.20")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/SWI-Prolog/swipl-devel.git")
+                    (url "https://github.com/SWI-Prolog/swipl-devel")
                     (recursive? #t) ; TODO: Determine if this can be split out.
                     (commit (string-append "V" version))))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1axdiz37dllw0ih58ffm0m95dfxqfzwahl48hpzq90rz4swcr1lq"))))
+                "1g0v9cmz8zvzc1n0si7sn6522xwzbhj2b8967ibs6prinrpjc8d6"))))
     (build-system cmake-build-system)
     (arguments
      `(#:parallel-build? #t
@@ -106,11 +106,9 @@ manner.  It also features an interactive interpreter.")
              "-DSWIPL_INSTALL_IN_LIB=OFF") ; FIXME: Breaks RUNPATH validation.
        #:phases
        (modify-phases %standard-phases
-         ;; XXX: Delete a variety of tests which fail either attempting to
-         ;; establish a network connection, or attempts to write to the
-         ;; immutable store. Phases marked *-pre are disabled /before/ building.
-         ;; Phases marked *-post are disabled /after/ building.
-         (add-after 'unpack 'delete-failing-tests-pre
+         ;; XXX: Delete the test phase that attempts to write to the
+         ;; immutable store.
+         (add-after 'unpack 'delete-failing-tests
            (lambda _
              (substitute* "src/CMakeLists.txt"
                ((" save") ""))
@@ -119,16 +117,6 @@ manner.  It also features an interactive interpreter.")
              (with-directory-excursion "src/Tests"
                (for-each delete-file-recursively
                          '("save")))
-             #t))
-         (add-before 'check 'delete-failing-tests-post
-           (lambda _
-             (with-directory-excursion "packages"
-               (for-each delete-file-recursively
-                         '("http"
-                           "pengines"
-                           "RDF"
-                           "semweb"
-                           "ssl")))
              #t)))))
     (native-inputs
      `(("zlib" ,zlib)
@@ -137,7 +125,7 @@ manner.  It also features an interactive interpreter.")
        ("texinfo" ,texinfo)
        ("libarchive" ,libarchive)
        ("libunwind" ,libunwind)
-       ("libjpeg"libjpeg-turbo)
+       ("libjpeg" ,libjpeg-turbo)
        ("libxft" ,libxft)
        ("fontconfig" ,fontconfig)
        ("perl" ,perl)