gnu: facter: Update to 4.0.33.
[jackhill/guix/guix.git] / gnu / packages / mastodon.scm
index 54d4c53..e7affc8 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
   #:use-module (guix build-system python)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages check)
+  #:use-module (gnu packages time)
+  #:use-module (gnu packages python-check)
+  #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz))
 
 (define-public toot
   (package
     (name "toot")
-    (version "0.24.0")
+    (version "0.27.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "toot" version))
         (sha256
-         (base32 "0w83b6ydaggrand9285wfrjrm1qry8fjl4as0iihma630ky6y2w3"))))
+         (base32 "1mfbqmgna7046d134pc5qx1vyfd60vwcn0xr9lxzlmc5rjdbmz8x"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (delete 'check)
-         (add-after 'install 'check
+         (replace 'check
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (add-installed-pythonpath inputs outputs)
              (invoke "py.test"))))))
@@ -64,3 +66,40 @@ Features include:
 @item Simple switching between authenticated in Mastodon accounts
 @end itemize")
     (license license:gpl3)))
+
+(define-public python-mastodon-py
+  (package
+    (name "python-mastodon-py")
+    (version "1.5.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "Mastodon.py" version))
+        (sha256
+         (base32
+          "1vikvkzcij2gd730cssigxi38vlmzqmwdy58r3y2cwsxifnxpz9a"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-blurhash" ,python-blurhash)
+       ("python-dateutil" ,python-dateutil)
+       ("python-decorator" ,python-decorator)
+       ("python-magic" ,python-magic)
+       ("python-pytz" ,python-pytz)
+       ("python-requests" ,python-requests)
+       ("python-six" ,python-six)))
+    (native-inputs
+     `(("python-blurhash" ,python-blurhash)
+       ("python-cryptography" ,python-cryptography)
+       ("python-http-ece" ,python-http-ece)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-mock" ,python-pytest-mock)
+       ("python-pytest-runner" ,python-pytest-runner)
+       ("python-pytest-vcr" ,python-pytest-vcr)
+       ("python-requests-mock" ,python-requests-mock)
+       ("python-vcrpy" ,python-vcrpy)))
+    (home-page "https://github.com/halcy/Mastodon.py")
+    (synopsis "Python wrapper for the Mastodon API")
+    (description
+     "This package provides a python wrapper for the Mastodon API.")
+    (license license:expat)))