gnu: Add go-github-com-emirpasic-gods-containers.
[jackhill/guix/guix.git] / gnu / packages / aidc.scm
index b68f213..944ea04 100644 (file)
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 John Darringon <jmd@gnu.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
@@ -91,7 +91,7 @@ characters, and is highly robust.")
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/dmtx/libdmtx.git")
+             (url "https://github.com/dmtx/libdmtx")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
@@ -157,39 +157,34 @@ Python as well as GUI widgets for GTK and Qt.")
     (license license:lgpl2.1+)))
 
 (define-public qrcodegen-cpp
-  ;; Currently this project's installation mechanism only exists as a GitHub
-  ;; pull request, so we build from a recent commit that the proposed patch
-  ;; applies to.
-  (let ((commit "6ea933f1596d818bd21e9a6b8d2e851fb8b4bcf1")
-        (revision "0"))
-    (package
-      (name "qrcodegen-cpp")
-      (version (git-version "1.5.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                       (url "https://github.com/nayuki/QR-Code-generator.git")
-                       (commit commit)))
-                (file-name (git-file-name name version))
-                (patches (search-patches "qrcodegen-cpp-make-install.patch"))
-                (sha256
-                 (base32
-                  "19fcwqmfk2n9p2n01dv2j4x2y2mqip0j1wbmfbxjp34rqkjwcwxm"))))
-      (build-system gnu-build-system)
-      (arguments
-       `(#:tests? #f ; no test suite
-         #:make-flags
-         (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
-         #:phases
-         (modify-phases %standard-phases
-           (delete 'configure) ; No ./configure script
-           ;; Only build the C++ variant.
-           (add-after 'unpack 'chdir
-             (lambda _
-               (chdir "cpp")
-               #t)))))
-      (synopsis "QR Code generator library")
-      (description "qrcodegen-cpp is a QR code generator library in C++.  The
+  (package
+    (name "qrcodegen-cpp")
+    (version "1.6.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/nayuki/QR-Code-generator")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (patches (search-patches "qrcodegen-cpp-make-install.patch"))
+              (sha256
+               (base32
+                "0iq9sv9na0vg996aqrxrjn9rrbiyy7sc9vslw945p3ky22pw3lql"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; no test suite
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure) ; No ./configure script
+         ;; Only build the C++ variant.
+         (add-after 'unpack 'chdir
+           (lambda _
+             (chdir "cpp")
+             #t)))))
+    (synopsis "QR Code generator library")
+    (description "qrcodegen-cpp is a QR code generator library in C++.  The
 project also offers Java, Javascript, Python, C, and Rust implementations.")
-      (home-page "https://www.nayuki.io/page/qr-code-generator-library")
-      (license license:expat))))
+    (home-page "https://www.nayuki.io/page/qr-code-generator-library")
+    (license license:expat)))