gnu: guix: Update snapshot.
[jackhill/guix/guix.git] / gnu / packages / vim.scm
index 0b532ae..e117fc4 100644 (file)
@@ -17,7 +17,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages vim)
-  #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
@@ -25,7 +25,7 @@
   #:use-module (gnu packages gawk)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
-  #:use-module (gnu packages system) ; For GNU hostname
+  #:use-module (gnu packages admin) ; For GNU hostname
   #:use-module (gnu packages tcsh))
 
 (define-public vim
      `(#:test-target "test"
        #:parallel-tests? #f
        #:phases
-        (alist-replace
-         'configure
-         (lambda* (#:key #:allow-other-keys #:rest args)
-          (let ((configure (assoc-ref %standard-phases 'configure)))
-           (apply configure args)
+        (alist-cons-after
+         'configure 'patch-config-files
+         (lambda _
            (substitute* "runtime/tools/mve.awk"
              (("/usr/bin/nawk") (which "gawk")))
            (substitute* "src/testdir/Makefile"
-             (("/bin/sh") (which "sh")))))
+             (("/bin/sh") (which "sh"))))
           %standard-phases)))
     (inputs
      `(("gawk", gawk)
        ("perl", perl)
        ("tcsh" ,tcsh))) ; For runtime/tools/vim32
     (home-page "http://www.vim.org/")
-    (synopsis "VIM 7.3, a text editor based on vi.")
+    (synopsis "Text editor based on vi")
     (description
      "Vim is a highly configurable text editor built to enable efficient text
-editing. It is an improved version of the vi editor distributed with most UNIX
+editing.  It is an improved version of the vi editor distributed with most UNIX
 systems.
 
 Vim is often called a \"programmer's editor,\" and so useful for programming
-that many consider it an entire IDE. It's not just for programmers, though. Vim
-is perfect for all kinds of text editing, from composing email to editing
-configuration files. ")
+that many consider it an entire IDE.  It's not just for programmers, though.
+Vim is perfect for all kinds of text editing, from composing email to editing
+configuration files.")
     (license license:vim)))