gnu: Add guile3.0-websocket.
[jackhill/guix/guix.git] / gnu / packages / gd.scm
index aac0f96..2d3ee42 100644 (file)
@@ -4,6 +4,8 @@
 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public gd
   (package
     (name "gd")
-
     ;; Note: With libgd.org now pointing to github.com, genuine old
     ;; tarballs are no longer available.  Notably, versions 2.0.x are
     ;; missing.
-    (version "2.2.4")
-
+    (version "2.2.5")
     (source (origin
              (method url-fetch)
              (uri (string-append
                    version "/libgd-" version ".tar.xz"))
              (sha256
               (base32
-               "1rp4v7n1dq38b92kl7gkvpvqqkw7nvdfnz6d5kip5klkxfki6zqk"))
-             (patches (search-patches "gd-fix-gd2-read-test.patch"
+               "0lfy5f241sbv8s3splm2zqiaxv7lxrcshh875xryryk7yk5jqc4c"))
+
+             (patches (search-patches "gd-CVE-2018-5711.patch"
+                                      "gd-CVE-2018-1000222.patch"
+                                      "gd-CVE-2019-6977.patch"
+                                      "gd-CVE-2019-6978.patch"
                                       "gd-fix-tests-on-i686.patch"
-                                      "gd-freetype-test-failure.patch"
-                                      "gd-php-73968-Fix-109-XBM-reading.patch"))))
+                                      "gd-freetype-test-failure.patch"))))
     (build-system gnu-build-system)
     (arguments
       ;; As recommended by github.com/libgd/libgd/issues/278 to fix rounding
@@ -80,7 +83,7 @@
     (propagated-inputs
      `(("fontconfig" ,fontconfig)
        ("libjpeg" ,libjpeg)))
-    (home-page "http://www.libgd.org/")
+    (home-page "https://www.libgd.org/")
     (synopsis "Library for the dynamic creation of images by programmers")
     (description
      "GD is a library for the dynamic creation of images by programmers.  GD
@@ -96,45 +99,27 @@ most common applications of GD involve website development.")
 (define-public perl-gd
   (package
     (name "perl-gd")
-    (version "2.56")
+    (version "2.71")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "mirror://cpan/authors/id/L/LD/LDS/"
+       (uri (string-append "mirror://cpan/authors/id/R/RU/RURBAN/"
                            "GD-" version ".tar.gz"))
        (sha256
-        (base32
-         "1ya8f9hpiax8j29vwaiwlvvgah0vkyvpzva28r8231nyk0f3s40z"))
-       (patches (search-patches
-                 "perl-gd-options-passthrough-and-fontconfig.patch"))))
+        (base32 "1ivskdb4nwy7ky37369hwkfxp11fkp6ri5k7qlf2dmra7f3y86s5"))))
     (build-system perl-build-system)
-    (native-inputs
-     `(("perl-module-build" ,perl-module-build))) ;needs Module::Build >= 0.42
     (inputs
-     `(("gd" ,gd)
-       ("zlib" ,zlib)
-       ("png" ,libpng)
-       ("ft" ,freetype)
-       ("jpeg" ,libjpeg)
-       ("fontconfig" ,fontconfig)))
+     `(("fontconfig" ,fontconfig)
+       ("freetype" ,freetype)
+       ("gd" ,gd)
+       ("libpng" ,libpng)
+       ("libjpeg" ,libjpeg)
+       ("zlib" ,zlib)))
     (arguments
-     ;; We must use Build.PL for building because Makefile.PL fails to build
-     ;; the XS source.
-     `(#:module-build-flags (map (lambda (i)
-                                   (string-append "--lib_" i "_path="
-                                                  (assoc-ref %build-inputs i)))
-                                 '("zlib" "png" "ft" "jpeg" "fontconfig"))
-       #:tests? #f ;; Failed 1/2 test programs. 1/12 subtests failed.
-       #:phases (alist-cons-after
-                 'configure 'clear-autogenerated-files
-                 (lambda _
-                   ;; This file is autogenerated by its .PLS script at build
-                   ;; time, but file creation fails because that file already
-                   ;; exists in the distribution with non-writable
-                   ;; permissions, so delete it first.
-                   (delete-file "bdf_scripts/bdf2gdfont.pl"))
-                 %standard-phases)))
-    (home-page "http://search.cpan.org/dist/GD")
+     `(#:make-maker-flags
+       (list (string-append "--lib_jpeg_path="
+                            (assoc-ref %build-inputs "libjpeg")))))
+    (home-page "https://metacpan.org/release/GD")
     (synopsis "Perl interface to the GD graphics library")
     (description "GD.pm is an autoloadable interface module for libgd, a
 popular library for creating and manipulating PNG files.  With this library
@@ -144,22 +129,26 @@ you can create PNG images on the fly or modify existing files.")
 (define-public perl-gd-securityimage
   (package
     (name "perl-gd-securityimage")
-    (version "1.73")
+    (version "1.75")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://cpan/authors/id/B/BU/BURAK/"
                            "GD-SecurityImage-" version ".tar.gz"))
        (sha256
-        (base32
-         "1kaxs67rfd4w46lxgcg3pa05a596l0h1k8n4zk2gwrrar4022wpx"))))
+        (base32 "19lf1kzdavrkkx3f900jnpynr55d5kjd2sdmwpfir5dsmkcj9pix"))))
     (build-system perl-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'set-env
+           (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1") #t)))))
     (native-inputs
      `(("perl-module-build" ,perl-module-build)))
     (propagated-inputs
      `(("perl-gd" ,perl-gd)
        ("perl-image-magick" ,perl-image-magick)))
-    (home-page "http://search.cpan.org/dist/GD-SecurityImage")
+    (home-page "https://metacpan.org/release/GD-SecurityImage")
     (synopsis "Security image generator")
     (description "This module provides a basic interface to create
 security (captcha) images.  The final output is the actual graphic data, the