Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / backup.scm
index c2dfc0f..1ef4e42 100644 (file)
@@ -3,6 +3,9 @@
 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
 ;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
+;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017 Kei Kebreau <kei@openmailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -24,7 +27,6 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix download)
   #:use-module (guix utils)
-  #:use-module (guix build utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
   #:use-module (gnu packages)
@@ -43,6 +45,7 @@
   #:use-module (gnu packages mcrypt)
   #:use-module (gnu packages nettle)
   #:use-module (gnu packages pcre)
+  #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages rsync)
@@ -53,7 +56,7 @@
 (define-public duplicity
   (package
     (name "duplicity")
-    (version "0.7.11")
+    (version "0.7.12")
     (source
      (origin
       (method url-fetch)
                           version ".tar.gz"))
       (sha256
        (base32
-        "01zcq9cwn4pvj68rihgjvcdgccnxvz4jrba38sbv6nqz19cs2ixh"))))
+        "1rhgrz2lm9vbfdp2raykrih1c6n2lw5jd572z4dsz488m52avjqi"))))
     (build-system python-build-system)
     (native-inputs
      `(("util-linux" ,util-linux)     ;setsid command, for the tests
+       ("par2cmdline" ,par2cmdline)
        ("python-pexpect" ,python2-pexpect)
        ("mock" ,python2-mock)))
     (propagated-inputs
        #:test-target "test"
        #:phases
        (modify-phases %standard-phases
-         (add-before
-          'build 'patch-source ; embed gpg store name
-          (lambda* (#:key inputs #:allow-other-keys)
-            (substitute* "duplicity/gpginterface.py"
-              (("self.call = 'gpg'")
-               (string-append "self.call = '" (assoc-ref inputs "gnupg") "/bin/gpg'")))))
-         (add-before 'check 'check-setup
+         (add-before 'build 'patch-source
            (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "testing/functional/__init__.py"
+             ;; embed gpg store name
+             (substitute* "duplicity/gpginterface.py"
+               (("self.call = 'gpg'")
+                (string-append "self.call = '" (assoc-ref inputs "gnupg") "/bin/gpg'")))
+             (substitute* '("testing/functional/__init__.py"
+                            "testing/overrides/bin/lftp")
                (("/bin/sh") (which "sh")))
+             #t))
+         (add-before 'check 'check-setup
+           (lambda* (#:key inputs #:allow-other-keys)
              (setenv "HOME" (getcwd)) ;gpg needs to write to $HOME
              (setenv "TZDIR"          ;some timestamp checks need TZDIR
                      (string-append (assoc-ref inputs "tzdata")
@@ -112,7 +118,7 @@ spying and/or modification by the server.")
 (define-public par2cmdline
   (package
     (name "par2cmdline")
-    (version "0.6.14")
+    (version "0.7.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/Parchive/par2cmdline/archive/v"
@@ -120,15 +126,7 @@ spying and/or modification by the server.")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0ykfb7ar0x0flfdgf6i8xphyv5b93dalbjj2jb6hx7sdjax33n1g"))
-              ;; This test merely needs a file to test recovery on, but
-              ;; /dev/random is essentially /dev/urandom plus minimum entropy
-              ;; locking, making the test hang indefinitely. This change is
-              ;; already upstream: remove on upgrade to future 0.6.15.
-              ;; https://github.com/Parchive/par2cmdline/commit/27723a678f780da82c79b98592592009c779a4fb
-              (modules '((guix build utils)))
-              (snippet
-               '(substitute* "tests/test20" (("if=/dev/random") "if=/dev/urandom")))))
+                "0rsrca7903g08zrifv4102gkxrhmzvgwd1sb6vw9pa00qhzsfkzs"))))
     (native-inputs
      `(("automake" ,automake)
        ("autoconf" ,autoconf)))
@@ -181,7 +179,7 @@ backups (called chunks) to allow easy burning to CD/DVD.")
 (define-public libarchive
   (package
     (name "libarchive")
-    (version "3.2.2")
+    (version "3.3.1")
     (source
      (origin
        (method url-fetch)
@@ -189,7 +187,7 @@ backups (called chunks) to allow easy burning to CD/DVD.")
                            version ".tar.gz"))
        (sha256
         (base32
-         "03q6y428rg723c9fj1vidzjw46w1vf8z0h95lkvz1l9jw571j739"))))
+         "1rr40hxlm9vy5z2zb5w7pyfkgd1a4s061qapm83s19accb8mpji9"))))
     (build-system gnu-build-system)
     ;; TODO: Add -L/path/to/nettle in libarchive.pc.
     (inputs
@@ -236,6 +234,20 @@ archive.  In particular, note that there is currently no built-in support for
 random access nor for in-place modification.")
     (license license:bsd-2)))
 
+(define libarchive-3.3.1
+  (package
+    (inherit libarchive)
+    (name "libarchive")
+    (version "3.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://libarchive.org/downloads/libarchive-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "1rr40hxlm9vy5z2zb5w7pyfkgd1a4s061qapm83s19accb8mpji9"))))))
+
 (define-public rdup
   (package
     (name "rdup")
@@ -365,6 +377,42 @@ to a remote location, and only the differences will be transmitted.  Finally,
 rdiff-backup is easy to use and settings have sensible defaults.")
     (license license:gpl2+)))
 
+(define-public rsnapshot
+  (package
+    (name "rsnapshot")
+    (version "1.4.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/rsnapshot/rsnapshot/releases/download/"
+             version "/rsnapshot-" version ".tar.gz"))
+       (sha256
+        (base32
+         "05jfy99a0xs6lvsjfp3wz21z0myqhmwl2grn3jr9clijbg282ah4"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (substitute* '("t/cmd-post_pre-exec/conf/pre-true-post-true.conf"
+                            "t/backup_exec/conf/backup_exec_fail.conf"
+                            "t/backup_exec/conf/backup_exec.conf")
+               (("/bin/true") (which "true"))
+               (("/bin/false") (which "false")))
+             (zero? (system* "make" "test")))))))
+    (inputs
+     `(("perl" ,perl)
+       ("rsync" ,rsync)))
+    (home-page "http://rsnapshot.org")
+    (synopsis "Deduplicating snapshot backup utility based on rsync")
+    (description "rsnapshot is a filesystem snapshot utility based on rsync.
+rsnapshot makes it easy to make periodic snapshots of local machines, and
+remote machines over SSH.  To reduce the disk space required for each backup,
+rsnapshot uses hard links to deduplicate identical files.")
+    (license license:gpl2+)))
+
 (define-public libchop
   (package
     (name "libchop")
@@ -483,7 +531,7 @@ detection, and lossless compression.")
        ("python-setuptools-scm" ,python-setuptools-scm)
        ;; Borg 1.0.8's test suite uses 'tmpdir_factory', which was introduced in
        ;; pytest 2.8.
-       ("python-pytest" ,python-pytest-2.9.2)
+       ("python-pytest" ,python-pytest-3.0)
        ;; For generating the documentation.
        ("python-sphinx" ,python-sphinx)
        ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
@@ -582,3 +630,57 @@ NTFS volumes using @code{ntfs-3g}, preserving NTFS-specific attributes.")
     (license (list license:gpl3+
                    license:lgpl3+
                    license:cc0))))
+
+(define-public obnam
+  (package
+    (name "obnam")
+    (version "1.21")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://code.liw.fi/debian/pool/main/o/obnam/obnam_"
+             version ".orig.tar.xz"))
+       (sha256
+        (base32
+         "0qlipsq50hca71zc0dp1mg9zs12qm0sbblw7qfzl0hj6mk2rv1by"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'check
+                  (lambda _
+                    (substitute* "obnamlib/vfs_local_tests.py"
+                      ;; Check for the nobody user instead of root
+                      (("self.fs.get_username\\(0\\), 'root'")
+                       "self.fs.get_username(65534), 'nobody'")
+                      ;; Disable tests checking for root group
+                      (("self.fs.get_groupname\\(0\\)") "'root'"))
+                    (substitute* "obnamlib/vfs_local.py"
+                      ;; Don't cover get_groupname function
+                      (("def get_groupname\\(self, gid\\):")
+                       "def get_groupname(self, gid):  # pragma: no cover"))
+                    ;; Can't run network tests
+                    (zero? (system* "./check" "--unit-tests")))))))
+    (inputs
+     `(("python2-cliapp" ,python2-cliapp)
+       ("python2-larch" ,python2-larch)
+       ("python2-paramiko" ,python2-paramiko)
+       ("python2-pyaml" ,python2-pyaml)
+       ("python2-tracing" ,python2-tracing)
+       ("python2-ttystatus" ,python2-ttystatus)))
+    (native-inputs
+     `(("gnupg" ,gnupg)
+       ("python2-coverage" ,python2-coverage)
+       ("python2-coverage-test-runner" ,python2-coverage-test-runner)
+       ("python2-pep8" ,python2-pep8)
+       ("python2-pylint" ,python2-pylint)))
+    (home-page "https://obnam.org/")
+    (synopsis "Easy and secure backup program")
+    (description "Obnam is an easy, secure backup program.  Features
+include snapshot backups, data de-duplication and encrypted backups
+using GnuPG.  Backups can be stored on local hard disks, or online via
+the SSH SFTP protocol.  The backup server, if used, does not require
+any special software, on top of SSH.")
+    (license license:gpl3+)))