gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / text-editors.scm
index 59286ce..47b6e93 100644 (file)
 (define-public vis
   (package
     (name "vis")
-    (version "0.6")                     ; also update the vis-test input
+    (version "0.7")                     ; also update the vis-test input
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/martanne/vis")
+             (url "https://git.sr.ht/~martanne/vis")
              (commit (string-append "v" version))))
        (sha256
-        (base32 "1zjm89cn3rfq8fxpwp66khy53s6vqlmw6q103qyyvix8ydzxdmsh"))
+        (base32 "1g05ncsnk57kcqm9wsv6sz8b24kyzj8r5rfpa1wfwj8qkjzx3vji"))
        (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/martanne/vis-test")
-                 (commit "4c4f6645de77f697a45899e8645e0c2bbdc7208a")))
+                 (url "https://git.sr.ht/~martanne/vis-test")
+                 (commit "bbd2f34ff788e87a51a74069069273ad83c44f1f")))
            (sha256
-            (base32 "10vh1pxsqw88a5xwh5irkm85xr66dbycmgpmabyw9h0vm14cvcz2"))
+            (base32 "1jsvg2lg3xqfgi79x08kx94mc34mh62ivca10vsci6fqsk68jbd0"))
            (file-name (git-file-name "vis-test" version))))))
     (inputs `(("lua" ,lua)
               ("ncurses" ,ncurses)
@@ -276,7 +276,7 @@ bindings and many of the powerful features of GNU Emacs.")
 (define-public jucipp
   (package
     (name "jucipp")
-    (version "1.6.2")
+    (version "1.6.3")
     (home-page "https://gitlab.com/cppit/jucipp")
     (source (origin
               (method git-fetch)
@@ -288,7 +288,7 @@ bindings and many of the powerful features of GNU Emacs.")
                                   (recursive? #t)))
               (file-name (git-file-name name version))
               (sha256
-               (base32 "10idv2kyw2dg45wfcnh7nybs8qys7kfvif90sjrff3541k97pm5y"))))
+               (base32 "1gy2xb5rm7q4zx9rl23h96b1i46fz27v25nklj50fvqp8ax2gxqy"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags '("-DBUILD_TESTING=ON"
@@ -358,11 +358,11 @@ bindings and many of the powerful features of GNU Emacs.")
        ("ctags" ,universal-ctags)
        ("gtkmm" ,gtkmm)
        ("gtksourceviewmm" ,gtksourceviewmm)
-       ("libclang" ,clang-10)     ;XXX: must be the same version as Mesas LLVM
+       ("libclang" ,clang-11)     ;XXX: must be the same version as Mesas LLVM
        ("libgit2" ,libgit2)))
     (synopsis "Lightweight C++ IDE")
     (description
-     "juCi++ is a small @dfn{IDE} (Integrated Development Environment)
+     "juCi++ is a small @acronym{IDE, Integrated Development Environment}
 designed especially towards libclang with speed, stability, and ease of use
 in mind.
 
@@ -861,14 +861,14 @@ Octave.  TeXmacs is completely extensible via Guile.")
 (define-public scintilla
   (package
     (name "scintilla")
-    (version "4.4.6")
+    (version "5.0.1")
     (source
      (origin
        (method url-fetch)
        (uri (let ((v (apply string-append (string-split version #\.))))
               (string-append "https://www.scintilla.org/scintilla" v ".tgz")))
        (sha256
-        (base32 "1p62dq2fgdkvdn2clz1xjdj09acv87rbifl67zhlz7skqip31y9d"))))
+        (base32 "0w5550fijkhmzvdydd8770qq9dgnbq1sd0a8rn4g6mwyfpcyhbfy"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags (list "GTK3=1" "CC=gcc" "-Cgtk")
@@ -888,7 +888,8 @@ Octave.  TeXmacs is completely extensible via Guile.")
                          (find-files "include/" "."))
                #t))))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
+     `(("gcc" ,gcc-9)                   ;Code has C++17 requirements
+       ("pkg-config" ,pkg-config)
        ("python" ,python-wrapper)))
     (inputs
      `(("gtk+" ,gtk+)))
@@ -965,7 +966,7 @@ The basic features of Geany are:
 (define-public fe
   (package
     (name "fe")
-    ;; Stable release is 1.8.  However, this development version
+    ;; Stable release is 1.9.  However, this development version
     ;; introduces support for UTF-8.
     (version "2.0")
     (source (origin
@@ -974,7 +975,7 @@ The basic features of Geany are:
                                   "fe-" version ".tar.gz"))
               (sha256
                (base32
-                "1hwws7si1752z6hp61zxznvgsb6846lp8zl1hn5ddhsbafwalwb9"))))
+                "10mk5wc3dsdp46b3hkjyd740gcdv6m1gvlr3p8xjxf55b3vfs0la"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ;no test