gnu: kdenlive: Add missing dependencies.
[jackhill/guix/guix.git] / gnu / packages / uml.scm
index d598ac0..f231b28 100644 (file)
@@ -1,5 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
+;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public plantuml
   (package
     (name "plantuml")
-    (version "8048")
+    (version "1.2020.16")
     (source (origin
               (method url-fetch)
-              (uri (string-append
-                    "mirror://sourceforge/plantuml/plantuml-"
-                    version ".tar.gz"))
+              (uri (string-append "mirror://sourceforge/plantuml/"
+                                  version "/plantuml-" version ".tar.gz"))
               (sha256
                (base32
-                "1vipxd6p7isb1k1qqh4hrpfcj27hx1nll2yp0rfwpvps1w2d936i"))))
+                "10ski6qq99rx98n5m9qs387c61jp40l7gqnbk290kay94x44phs7"))))
     (build-system ant-build-system)
     (arguments
-     `(#:tests? #f ; no tests
+     `(#:tests? #f                      ; no tests
        #:build-target "dist"
        #:phases
        (modify-phases %standard-phases
@@ -48,7 +50,7 @@
              (substitute* "build.xml"
                (("1.6") "1.7")
                (("<attribute name=\"Class-Path\"") "<!--")
-               (("j2v8_macosx_x86_64-3.1.7.jar\" />") "-->"))
+               (("ditaa0_9.jar\" />") "-->"))
              #t))
          (add-after 'delete-extra-from-classpath 'patch-usr-bin-dot
            (lambda* (#:key inputs #:allow-other-keys)
@@ -81,7 +83,7 @@
     (inputs
      `(("graphviz" ,graphviz)
        ("jre" ,icedtea)))
-    (home-page "http://plantuml.com/")
+    (home-page "https://plantuml.com/")
     (synopsis "Draw UML diagrams from simple textual description")
     (description
      "Plantuml is a tool to generate sequence, usecase, class, activity,