gnu: Use 'modify-phases' syntax.
[jackhill/guix/guix.git] / gnu / packages / pretty-print.scm
index 8ba9780..e971930 100644 (file)
@@ -1,6 +1,9 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,6 +24,7 @@
   #:use-module (guix packages)
   #:use-module (guix licenses)
   #:use-module (guix download)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages gperf)
-  #:use-module (gnu packages perl))
+  #:use-module (gnu packages lua)
+  #:use-module (gnu packages perl)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages compression))
 
 (define-public a2ps
   (package
     (name "a2ps")
     (version "4.14")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "mirror://gnu/a2ps/a2ps-"
-                          version ".tar.gz"))
-      (sha256
-       (base32
-        "195k78m1h03m961qn7jr120z815iyb93gwi159p1p9348lyqvbpk"))
-      (patches (search-patches
-                 "a2ps-CVE-2001-1593.patch"
-                 "a2ps-CVE-2014-0466.patch"))))
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/a2ps/a2ps-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "195k78m1h03m961qn7jr120z815iyb93gwi159p1p9348lyqvbpk"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; Remove timestamp from the installed 'README' file.
+               '(substitute* "etc/README.in"
+                  (("@date@")
+                   "1st of some month, sometime after 1970")))
+              (patches (search-patches
+                        "a2ps-CVE-2001-1593.patch"
+                        "a2ps-CVE-2014-0466.patch"))))
     (build-system gnu-build-system)
     (inputs
      `(("psutils" ,psutils)
                             "tests/gps-ref/psmandup.ps")
                (("#! */bin/sh") (string-append
                                  "#!" (which "sh")))))))))
-    (home-page "http://www.gnu.org/software/a2ps")
+    (home-page "https://www.gnu.org/software/a2ps/")
     (synopsis "Any file to PostScript, including pretty-printing")
     (description
      "GNU a2ps converts almost anything to a PostScript file, ready for
@@ -114,7 +126,7 @@ special cases, such as pretty-printing \"--help\" output.")
     (arguments
      ;; Must define DIFF_CMD for tests to pass
      '(#:configure-flags '("CPPFLAGS=-DDIFF_CMD=\\\"diff\\\"")))
-    (home-page "http://www.gnu.org/software/trueprint")
+    (home-page "https://www.gnu.org/software/trueprint/")
     (synopsis "Pretty-print C sources and other plain text to PostScript")
     (description
      "GNU Trueprint translates C source code files as PostScript files.
@@ -135,7 +147,7 @@ indentation counting, function and file indices and more.")
        (base32
         "1fy0ymvzrrvs889zanxcaxjfcxarm2d3k43c9frmbl1ld7dblmkd"))))
     (build-system gnu-build-system)
-    (home-page "http://www.gnu.org/software/enscript")
+    (home-page "https://www.gnu.org/software/enscript/")
     (synopsis "Generating PostScript, including pretty-printing")
     (description
      "GNU Enscript is a program to convert ASCII text files to PostScript,
@@ -144,6 +156,30 @@ It also includes the capability to perform syntax highlighting for several
 different programming languages.")
     (license gpl3+)))
 
+(define-public fmt
+  (package
+    (name "fmt")
+    (version "3.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/fmtlib/fmt/releases/download/"
+                    version "/fmt-" version ".zip"))
+              (sha256
+               (base32
+                "0l4514mk83cjimynci3ghrfdchjy8cya1qa45c1fg2lsj7fg16jc"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("unzip" ,unzip)))
+    (home-page "http://fmtlib.net/latest/")
+    (synopsis "Small and fast C++ formatting library")
+    (description
+     "@code{fmt} (formerly @code{cppformat}) is a formatting library for C++.
+It can be used as a safe alternative to @code{printf} or as a fast alternative
+to @code{IOStreams}.")
+    ;; The library is bsd-2, but documentation and tests include other licenses.
+    (license (list bsd-2 bsd-3 psfl))))
+
 (define-public source-highlight
   (package
     (name "source-highlight")
@@ -169,23 +205,24 @@ different programming languages.")
        (list (string-append "--with-boost="
                             (assoc-ref %build-inputs "boost")))
        #:parallel-tests? #f             ;There appear to be race conditions
-       #:phases (alist-cons-before
-                 'check 'patch-test-files
-                 (lambda _
-                   ;; Unpatch shebangs in test input so that source-highlight
-                   ;; is still able to infer input language
-                   (substitute* '("tests/test.sh"
-                                  "tests/test2.sh"
-                                  "tests/test.tcl")
-                     (((string-append "#! *" (which "sh"))) "#!/bin/sh"))
-                   ;; Initial patching unrecoverably removes whitespace, so
-                   ;; remove it also in the comparison output.
-                   (substitute* '("tests/test.sh.html"
-                                  "tests/test2.sh.html"
-                                  "tests/test.tcl.html")
-                     (("#! */bin/sh") "#!/bin/sh")))
-                 %standard-phases)))
-    (home-page "http://www.gnu.org/software/src-highlite")
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'patch-test-files
+           (lambda _
+             ;; Unpatch shebangs in test input so that source-highlight
+             ;; is still able to infer input language
+             (substitute* '("tests/test.sh"
+                            "tests/test2.sh"
+                            "tests/test.tcl")
+               (((string-append "#! *" (which "sh"))) "#!/bin/sh"))
+             ;; Initial patching unrecoverably removes whitespace, so
+             ;; remove it also in the comparison output.
+             (substitute* '("tests/test.sh.html"
+                            "tests/test2.sh.html"
+                            "tests/test.tcl.html")
+               (("#! */bin/sh") "#!/bin/sh"))
+             #t)))))
+    (home-page "https://www.gnu.org/software/src-highlite/")
     (synopsis "Produce a document with syntax highlighting from a source file")
     (description
      "GNU source-highlight reads in a source code file and produces an output
@@ -197,6 +234,47 @@ seen in a terminal.")
     (license gpl3+)
     (properties '((ftp-directory . "/gnu/src-highlite")))))
 
+(define-public highlight
+  (package
+    (name "highlight")
+    (version "3.33")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://www.andre-simon.de/zip/highlight-"
+                           version ".tar.bz2"))
+       (sha256
+        (base32
+         "0g2whi6pxl640795vymikm82a1my841jmh7fiqzbrjpc9wsk1db4"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; no tests
+       #:make-flags
+       (let ((confdir (string-append %output "/share/highlight/config/")))
+         (list (string-append "PREFIX=" %output)
+               (string-append "HL_CONFIG_DIR=" confdir)
+               (string-append "conf_dir=" confdir)))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (add-after 'unpack 'fix-search-for-lua
+           (lambda _
+             (substitute* "src/makefile"
+               (("(pkg-config.*)lua" _ prefix)
+                (string-append prefix "lua-5.3")))
+             #t)))))
+    (inputs
+     `(("lua" ,lua)
+       ("boost" ,boost)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://www.andre-simon.de/doku/highlight/en/highlight.php")
+    (synopsis "Convert code to documents with syntax highlighting")
+    (description "Highlight converts source code to HTML, XHTML, RTF, LaTeX,
+TeX, SVG, BBCode and terminal escape sequences with colored syntax
+highlighting.  Language definitions and color themes are customizable.")
+    (license gpl3+)))
+
 (define-public astyle
   (package
     (name "astyle")
@@ -215,22 +293,22 @@ seen in a terminal.")
        #:make-flags (list (string-append "prefix=" %output)
                           "INSTALL=install"
                           "all")
-       #:phases (alist-replace
-                 'configure
-                 (lambda _ (chdir "build/gcc"))
-                 (alist-cons-after
-                  'install 'install-libs
-                  (lambda* (#:key outputs #:allow-other-keys)
-                    ;; Libraries are not installed by default
-                    (let* ((output (assoc-ref outputs "out"))
-                           (libdir (string-append output "/lib")))
-                      (begin
-                        (mkdir-p libdir)
-                        (for-each (lambda (l)
-                                    (copy-file
-                                     l (string-append libdir "/" (basename l))))
-                                  (find-files "bin" "lib*")))))
-                  %standard-phases))))
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda _ (chdir "build/gcc") #t))
+         (add-after 'install 'install-libs
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Libraries are not installed by default
+             (let* ((output (assoc-ref outputs "out"))
+                    (libdir (string-append output "/lib")))
+               (begin
+                 (mkdir-p libdir)
+                 (for-each (lambda (l)
+                             (copy-file
+                              l (string-append libdir "/" (basename l))))
+                           (find-files "bin" "lib*"))))
+             #t)))))
     (home-page "http://astyle.sourceforge.net/")
     (synopsis "Source code indenter, formatter, and beautifier")
     (description