gnu: git-annex: Update to 8.20200330.
[jackhill/guix/guix.git] / gnu / packages / hardware.scm
index 52bc3d0..4c9c45b 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (gnu packages glib)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages))
 
 (define-public ddcutil
   (package
     (name "ddcutil")
-    (version "0.9.2")
+    (version "0.9.8")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.ddcutil.com/tarballs/"
-                           name "-" version ".tar.gz"))
+                           "ddcutil-" version ".tar.gz"))
        (sha256
-        (base32 "0nhi261vf2n3jpi0a0n6659911kxi3lj7a4h7cmv0ip6sbb8rk88"))))
+        (base32 "13ccxbqgyz4ah9jwbcylnfkgl8j3ida8xd00xkcq4xnfyyv5mg6v"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -232,3 +234,45 @@ such as the Turbo Boost ratio and Thermal Design Power (@dfn{TDP}) limits.
 MSR addresses differ (greatly) between processors, and any such modification can
 be dangerous and may void your CPU or system board's warranty.")
     (license license:gpl2)))     ; cpuid.c is gpl2, {rd,wr}msr.c are gpl2+
+
+(define-public wavemon
+  (package
+    (name "wavemon")
+    (version "0.9.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/uoaerg/wavemon.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "109ycwnjjqc2vpnd8b86njfifczlxglnyv4rh2qmbn2i5nw2wryg"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags
+       (list "CC=gcc"
+             ;; Makefile.in (ab)uses $(datadir) as $(docdir). Set it to Guix's
+             ;; standard --docdir since it's only used as such.
+             (string-append "datadir=" (assoc-ref %outputs "out")
+                            "/share/doc/" ,name "-" ,version))
+       #:tests? #f))                    ; no tests
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libcap" ,libcap)
+       ("libnl" ,libnl)
+       ("ncurses" ,ncurses)))
+    (home-page "https://github.com/uoaerg/wavemon")
+    (synopsis "Wireless network device monitor")
+    (description
+     "Wavemon is a wireless device monitor with an interactive ncurses terminal
+interface.  It can display and plot signal and noise levels in real time.  It
+also reports packet statistics, device configuration, network parameters, and
+access points and other wireless clients of your wireless network hardware.
+
+Wavemon should work (with varying levels of detail and features) with any device
+supported by the Linux kernel.")
+    ;; Source file headers still say GPL2+, but the authorial intent
+    ;; (from COPYING and the F9 'about' screen) is clearly GPL3+.
+    (license license:gpl3+)))