gnu: calibre: Build with non-modular Qt.
[jackhill/guix/guix.git] / gnu / packages / gstreamer.scm
index c32e480..a39a3b4 100644 (file)
@@ -1,5 +1,9 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages gstreamer)
-  #:use-module ((guix licenses) #:select (lgpl2.0+))
+  #:use-module ((guix licenses) #:select (lgpl2.0+ lgpl2.1+ bsd-2 bsd-3 gpl2+))
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix utils)
   #:use-module (gnu packages)
+  #:use-module (gnu packages audio)
   #:use-module (gnu packages bison)
+  #:use-module (gnu packages cdrom)
+  #:use-module (gnu packages curl)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages flex)
+  #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
+  #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages graphics)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages image)
+  #:use-module (gnu packages libusb)
+  #:use-module (gnu packages linux)
+  #:use-module (gnu packages mp3)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages pulseaudio)
+  #:use-module (gnu packages qt)
+  #:use-module (gnu packages rdf)
+  #:use-module (gnu packages video)
+  #:use-module (gnu packages xorg)
+  #:use-module (gnu packages xiph)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages ssh)
+  #:use-module (gnu packages telephony)
+  #:use-module (gnu packages tls)
+  #:use-module (gnu packages version-control)
+  #:use-module (gnu packages assembly)
   #:use-module (gnu packages xml))
 
+(define-public orc
+  (package
+    (name "orc")
+    (version "0.4.25")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://gstreamer.freedesktop.org/data/src/"
+                                  "orc/orc-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1lak3hyvvb0w9avzmf0a8vayb7vqhj4m709q1czlhvgjb15dbcf1"))))
+    (build-system gnu-build-system)
+    (arguments `(#:phases
+                 (alist-cons-before
+                  'check 'disable-faulty-test
+                  (lambda _
+                    ;; XXX Disable the 'test-limits' and 'exec_opcodes_sys'
+                    ;; tests, which fail on some machines.  See:
+                    ;; https://bugzilla.gnome.org/show_bug.cgi?id=735273
+                    (substitute* '("testsuite/test-limits.c"
+                                   "testsuite/exec_opcodes_sys.c")
+                      (("if \\(error\\) return 1;")
+                       "if (error) return 77;")))
+                  %standard-phases)))
+    (home-page "http://code.entropywave.com/orc/")
+    (synopsis "Oil runtime compiler")
+    (description
+     "Orc is a just-in-time compiler implemented as a library and set of
+associated tools for compiling and executing simple programs that operate on
+arrays of data.")
+    ;; The source code implementing the Marsenne Twister algorithm is licensed
+    ;; under the 3-clause BSD license, the rest is under 2-clause BSD license.
+    (license (list bsd-2 bsd-3))))
+
 (define-public gstreamer
   (package
     (name "gstreamer")
-    (version "1.0.10")
+    (version "1.8.2")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
-                          version ".tar.xz"))
+      (uri (string-append
+            "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
+            version ".tar.xz"))
       (sha256
        (base32
-        "0c0irk85jd2cihm5pmf4zxhlpg08qpxjcqv1l9qn2n3h2gsaj2lf"))))
+        "0hc3j684nx209p10ampvnkza3gna2yiryr7jyx701ciakh3vxglx"))))
     (build-system gnu-build-system)
-    (inputs
+    (outputs '("out" "doc"))
+    (arguments
+     `(#:configure-flags
+       (list (string-append "--with-html-dir="
+                            (assoc-ref %outputs "doc")
+                            "/share/gtk-doc/html"))))
+    (propagated-inputs `(("glib" ,glib))) ; required by gstreamer-1.0.pc.
+    (native-inputs
      `(("bison" ,bison)
        ("flex" ,flex)
-       ("glib" ,glib)
+       ("glib" ,glib "bin")
+       ("gobject-introspection" ,gobject-introspection)
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("python-wrapper" ,python-wrapper)))
-    (home-page "http://gstreamer.freedesktop.org/")
-    (synopsis
-     "Multimedia library")
+    (native-search-paths
+     (list (search-path-specification
+            (variable "GST_PLUGIN_SYSTEM_PATH")
+            (files '("lib/gstreamer-1.0")))))
+    (home-page "https://gstreamer.freedesktop.org/")
+    (synopsis "Multimedia library")
     (description
      "GStreamer is a library for constructing graphs of media-handling
 components.  The applications it supports range from simple Ogg/Vorbis
-playback, audio/video streaming to complex audio (mixing) and video
-(non-linear editing) processing.
+playback, audio/video streaming to complex audio mixing and video
+non-linear editing.
 
 Applications can take advantage of advances in codec and filter technology
 transparently.  Developers can add new codecs and filters by writing a
@@ -66,70 +142,319 @@ simple plugin with a clean, generic interface.
 This package provides the core library and elements.")
     (license lgpl2.0+)))
 
-(define-public gstreamer-0.10
-  (package (inherit gstreamer)
-    (version "0.10.36")
+(define-public gst-plugins-base
+  (package
+    (name "gst-plugins-base")
+    (version "1.8.2")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
-                          version ".tar.xz"))
+      (uri (string-append "https://gstreamer.freedesktop.org/src/" name "/"
+                          name "-" version ".tar.xz"))
       (sha256
        (base32
-        "1nkid1n2l3rrlmq5qrf5yy06grrkwjh3yxl5g0w58w0pih8allci"))
-      (patches
-        (list (search-patch "gstreamer-0.10-bison3.patch")
-              (search-patch "gstreamer-0.10-silly-test.patch")))))
+        "13fk751vvfrfhbm4ip28vxyvlsm4b4y0bc0pvf7fqp8azg40jwcx"))))
+    (build-system gnu-build-system)
+    (outputs '("out" "doc"))
     (propagated-inputs
-     `(("libxml2" ,libxml2)))
+     `(("gstreamer" ,gstreamer))) ; required by gstreamer-plugins-base-1.0.pc
     (inputs
-     `(("bison" ,bison)
-       ("flex" ,flex)
-       ("glib" ,glib)
-       ("perl" ,perl)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python-2)))))
+     `(("cdparanoia" ,cdparanoia)
+       ("orc" ,orc)
+       ("pango" ,pango)
+       ("libogg" ,libogg)
+       ("libtheora" ,libtheora)
+       ("libvorbis" ,libvorbis)
+       ("libx11" ,libx11)
+       ("zlib" ,zlib)
+       ("libXext" ,libxext)
+       ("libxv" ,libxv)
+       ("alsa-lib" ,alsa-lib)))
+    (native-inputs
+      `(("pkg-config" ,pkg-config)
+        ("glib" ,glib "bin")
+        ("gobject-introspection" ,gobject-introspection)
+        ("python-wrapper" ,python-wrapper)))
+    (arguments
+     `(#:parallel-tests? #f ; 'pipelines/tcp' fails in parallel
+       #:configure-flags
+       (list (string-append "--with-html-dir="
+                            (assoc-ref %outputs "doc")
+                            "/share/gtk-doc/html"))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'patch
+           (lambda _
+             (substitute* "tests/check/libs/pbutils.c"
+               (("/bin/sh") (which "sh"))))))))
+    (home-page "https://gstreamer.freedesktop.org/")
+    (synopsis
+     "Plugins for the GStreamer multimedia library")
+    (description "This package provides an essential exemplary set of plug-ins
+for the GStreamer multimedia library.")
+    (license lgpl2.0+)))
 
-(define-public gst-plugins-base
+
+(define-public gst-plugins-good
   (package
-    (name "gst-plugins-base")
-    (version "1.0.10")
+    (name "gst-plugins-good")
+    (version "1.8.2")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-"
-                          version ".tar.xz"))
+      (uri (string-append
+            "https://gstreamer.freedesktop.org/src/" name "/"
+            name "-" version ".tar.xz"))
       (sha256
        (base32
-        "1s4pphbb5kpdh4rrmb8rala4sp499k4by59925k15xiz58xyhm4p"))))
+        "0i1rlbbx3m6ykvcdyaidsd8wa2b7nq2qmcvbrsg00yivi88ljxcd"))))
     (build-system gnu-build-system)
-    ;; FIXME: Add more dependencies for further plugins.
     (inputs
-     `(("glib" ,glib)
-       ("gstreamer" ,gstreamer)
+     `(("aalib" ,aalib)
+       ("cairo" ,cairo)
+       ("flac" ,flac)
+       ("gdk-pixbuf" ,gdk-pixbuf)
+       ("gst-plugins-base" ,gst-plugins-base)
+       ("jack" ,jack-1)
+       ("libavc1394" ,libavc1394)
+       ("libcaca" ,libcaca)
+       ("libdv" ,libdv)
+       ("libiec61883" ,libiec61883)
+       ("libjpeg" ,libjpeg)
+       ("libpng" ,libpng)
+       ("libshout" ,libshout)
+       ("libsoup" ,libsoup)
+       ("libvpx" ,libvpx)
+       ("orc" ,orc)
+       ("pulseaudio" ,pulseaudio)
+       ("speex" ,speex)
+       ("taglib" ,taglib)
+       ("wavpack" ,wavpack)))
+    (native-inputs
+     `(("glib:bin" ,glib "bin")
        ("pkg-config" ,pkg-config)
        ("python-wrapper" ,python-wrapper)))
     (arguments
-     `(#:tests? #f))
-      ;; All tests pass except for one:
-      ;; Running suite(s): pbutils library
-      ;; 85%: Checks: 7, Failures: 1, Errors: 0
-      ;; libs/pbutils.c:522:F:general:test_pb_utils_install_plugins:0: gst_install_plugins_sync() failed ;; with unexpected ret 201, which is neither HELPER_MISSING nor 1
-      ;; FAIL: libs/pbutils
-      ;; According to the documentation, "gst_install_plugins_sync (...)
-      ;; should almost never be used".
-    (home-page "http://gstreamer.freedesktop.org/")
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after
+          'unpack 'disable-failing-tests
+          (lambda _
+            ;; Disable tests that fail non-deterministically.
+            ;; XXX FIXME: Try removing this for version > 1.8.0.
+            (substitute* "tests/check/elements/rtprtx.c"
+              (("tcase_add_test \\(tc_chain, test_push_forward_seq\\);" all)
+               (string-append "/* " all " */"))
+              (("tcase_add_test \
+\\(tc_chain, test_rtxreceive_data_reconstruction\\);" all)
+               (string-append "/* " all " */")))
+            (substitute* "tests/check/elements/splitmux.c"
+              (("tcase_add_test \\(tc_chain, test_splitmuxsink\\);" all)
+               (string-append "/* " all " */")))
+            #t)))))
+    (home-page "https://gstreamer.freedesktop.org/")
     (synopsis
-     "Plugins for the gstreamer multimedia library")
-    (description
-     "GStreamer is a library for constructing graphs of media-handling
-components.  The applications it supports range from simple Ogg/Vorbis
-playback, audio/video streaming to complex audio (mixing) and video
-(non-linear editing) processing.
+     "Plugins for the GStreamer multimedia library")
+    (description "GStreamer Good Plug-ins is a set of plug-ins for the
+GStreamer multimedia library.  This set contains those plug-ins which the
+developers consider to have good quality code and correct functionality.")
+    (license lgpl2.0+)))
 
-Applications can take advantage of advances in codec and filter technology
-transparently.  Developers can add new codecs and filters by writing a
-simple plugin with a clean, generic interface.
+(define-public gst-plugins-bad
+  (package
+    (name "gst-plugins-bad")
+    (version "1.6.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://gstreamer.freedesktop.org/src/"
+                                  name "/" name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0q9s5da54819gwncmdi95l5qzx97l9vxk6adx4zmx73a3l82j6wp"))))
+    (outputs '("out" "doc"))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f ; XXX: 11 of 54 tests fail
+       #:configure-flags
+       (list (string-append "--with-html-dir="
+                            (assoc-ref %outputs "doc")
+                            "/share/gtk-doc/html"))))
+    (propagated-inputs
+     `(("gst-plugins-base" ,gst-plugins-base)))
+    (native-inputs
+     `(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
+       ("gobject-introspection" ,gobject-introspection)
+       ("pkg-config" ,pkg-config)
+       ("python" ,python)))
+    (inputs
+     ;; XXX: The following dependencies are missing:
+     ;;  vo-amrwbenc, vo-aacenc, bs2b, chromaprint, directfb, daala, libdts,
+     ;;  faac, flite, libgsm, libde265, libmms, libmimic, mjpegtools,
+     ;;  mpeg2enc, libofa, opencv, openh264, openni2, libtimemmgr, wildmidi,
+     ;;  openspc, gme, sbc, schroedinger, zbar, librtmp, spandsp, x265
+     `(("bluez" ,bluez)
+       ("curl" ,curl)
+       ("faad2" ,faad2)
+       ("fluidsynth" ,fluidsynth)
+       ("gtk+" ,gtk+)
+       ("ladspa" ,ladspa)
+       ("libass" ,libass)
+       ("libdvdnav" ,libdvdnav)
+       ("libdvdread" ,libdvdread)
+       ("libgcrypt" ,libgcrypt)
+       ("libgudev" ,libgudev)
+       ("libkate" ,libkate)
+       ("libmodplug" ,libmodplug)
+       ("librsvg" ,librsvg)
+       ("libsndfile" ,libsndfile)
+       ("libsrtp" ,libsrtp)
+       ("libssh2" ,libssh2)
+       ("libusb" ,libusb)
+       ("libvdpau" ,libvdpau)
+       ("libwebp" ,libwebp)
+       ("libxml2" ,libxml2)
+       ("lrdf" ,lrdf)
+       ("mesa" ,mesa)
+       ("mpg123" ,mpg123)
+       ("neon" ,neon)
+       ("openal" ,openal)
+       ("openexr" ,openexr)
+       ("openjpeg" ,openjpeg)
+       ("openssl" ,openssl)
+       ("opus" ,opus)
+       ("orc" ,orc)
+       ("qt" ,qt)
+       ("soundtouch" ,soundtouch)
+       ("wayland" ,wayland)))
+    (home-page "http://gstreamer.freedesktop.org/")
+    (synopsis "Plugins for the GStreamer multimedia library")
+    (description
+     "GStreamer Bad Plug-ins is a set of plug-ins whose quality aren't up to
+par compared to the rest.")
+    (license lgpl2.0+)))
 
-This package provides an essential exemplary set of elements.")
+(define-public gst-plugins-ugly
+  (package
+    (name "gst-plugins-ugly")
+    (version "1.8.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://gstreamer.freedesktop.org/src/"
+                           name "/" name "-" version ".tar.xz"))
+       (sha256
+        (base32
+         "1b58s7z430cbbaw8mgy87kslbpmj3xmm66wsr7bddhcgm6i36nww"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("gst-plugins-base" ,gst-plugins-base)
+       ("liba52" ,liba52)
+       ("libmad" ,libmad)
+       ("lame" ,lame)
+       ("libcdio" ,libcdio)
+       ("twolame" ,twolame)
+       ("libmpeg2" ,libmpeg2)
+       ("libdvdread" ,libdvdread)
+       ("libx264" ,libx264)
+       ;; TODO:
+       ;; * opencore-amr (for the AMR-NB decoder and encoder and the
+       ;;   AMR-WB decoder) <http://sourceforge.net/projects/opencore-amr/>
+       ("orc" ,orc)))
+    (native-inputs
+     `(("glib:bin" ,glib "bin")
+       ("pkg-config" ,pkg-config)
+       ("python-wrapper" ,python-wrapper)))
+    (home-page "https://gstreamer.freedesktop.org/")
+    (synopsis "GStreamer plugins from the \"ugly\" set")
+    (description "GStreamer Ugly Plug-ins.  This set contains those plug-ins
+which the developers consider to have good quality code but that might pose
+distribution problems in some jurisdictions, e.g. due to patent threats.")
     (license lgpl2.0+)))
+
+(define-public gst-libav
+  (package
+    (name "gst-libav")
+    (version "1.8.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://gstreamer.freedesktop.org/src/" name "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0yk8pxg3xi26ndj7pliqdfphy0jmqsq4dmdzy31gbd9rgficgwxm"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags '("--with-system-libav")
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'patch-/bin/sh
+                     (lambda _
+                       (substitute* "gst-libs/ext/libav/configure"
+                         (("#! /bin/sh")
+                          (string-append "#! "(which "sh")))))))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("python" ,python)))
+    (inputs
+     `(("gst-plugins-base" ,gst-plugins-base)
+       ("ffmpeg" ,ffmpeg)
+       ("orc" ,orc)
+       ("zlib" ,zlib)))
+    (home-page "http://gstreamer.freedesktop.org/")
+    (synopsis "Plugins for the GStreamer multimedia library")
+    (description
+     "This GStreamer plugin supports a large number of audio and video
+compression formats through the use of the libav library.")
+    (license gpl2+)))
+
+(define-public python-gst
+  (package
+    (name "python-gst")
+    (version "1.8.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://gstreamer.freedesktop.org/src/gst-python/"
+                    "gst-python-" version ".tar.xz"))
+              (sha256
+               (base32
+                "15sdfa6lq5pswvi09vk51cs30yf8wr2rlm9myhb4q0c2jhiial2g"))))
+    (build-system gnu-build-system)
+    (arguments
+     ;; XXX: Factorize python-sitedir with python-build-system.
+     `(#:imported-modules (,@%gnu-build-system-modules
+                           (guix build python-build-system))
+       #:configure-flags
+       (let* ((python (assoc-ref %build-inputs "python"))
+              (python-version ((@@ (guix build python-build-system)
+                                   get-python-version)
+                               python))
+              (python-sitedir (string-append
+                               "lib/python" python-version "/site-packages")))
+         (list (string-append
+                "--with-pygi-overrides-dir=" %output "/" python-sitedir
+                "/gi/overrides")))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("python" ,python)))
+    (propagated-inputs
+     `(("gst-plugins-base" ,gst-plugins-base)
+       ("python-pygobject" ,python-pygobject)))
+    (home-page "https://gstreamer.freedesktop.org/")
+    (synopsis "GStreamer GObject Introspection overrides for Python")
+    (description
+     "This package contains GObject Introspection overrides for Python that can
+be used by Python applications using GStreamer.")
+    (license lgpl2.1+)
+    (properties `((python2-variant . ,(delay python2-gst))))))
+
+(define-public python2-gst
+  (package (inherit python-gst)
+    (name "python2-gst")
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("python" ,python-2)))
+    (propagated-inputs
+     `(("gst-plugins-base" ,gst-plugins-base)
+       ("python-pygobject" ,python2-pygobject)))))