gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / kerberos.scm
index bf344ce..20ed94b 100644 (file)
@@ -5,10 +5,11 @@
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2012, 2013 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2012, 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -34,6 +35,7 @@
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages libidn)
+  #:use-module (gnu packages hurd)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages compression)
@@ -50,7 +52,7 @@
 (define-public mit-krb5
   (package
     (name "mit-krb5")
-    (version "1.17")
+    (version "1.18")
     (source (origin
               (method url-fetch)
               (uri (list
                     (string-append "https://kerberos.org/dist/krb5/"
                                    (version-major+minor version)
                                    "/krb5-" version ".tar.gz")))
+              (patches (search-patches "mit-krb5-qualify-short-hostnames.patch"
+                                       "mit-krb5-hurd.patch"))
               (sha256
                (base32
-                "1xc1ly09697b7g2vngvx76szjqy9769kpgn27lnp1r9xln224vjs"))))
+                "121c5xsy3x0i4wdkrpw62yhvji6virbh6n30ypazkp0isws3k4bk"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("bison" ,bison)
 
        ,@(if (%current-target-system)
              '(#:configure-flags
-               (list "krb5_cv_attr_constructor_destructor=yes"
+               (list "--localstatedir=/var"
+                     "krb5_cv_attr_constructor_destructor=yes"
                      "ac_cv_func_regcomp=yes"
                      "ac_cv_printf_positional=yes"
                      "ac_cv_file__etc_environment=yes"
                      "ac_cv_file__etc_TIMEZONE=no")
                #:make-flags
                (list "CFLAGS+=-DDESTRUCTOR_ATTR_WORKS=1"))
-             '())
+             '(#:configure-flags
+               (list "--localstatedir=/var")))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'enter-source-directory
@@ -110,7 +116,7 @@ authentication for client/server applications by using secret-key
 cryptography.")
     (license (license:non-copyleft "file://NOTICE"
                                    "See NOTICE in the distribution."))
-    (home-page "http://web.mit.edu/kerberos/")
+    (home-page "https://web.mit.edu/kerberos/")
     (properties '((cpe-name . "kerberos")))))
 
 (define-public shishi
@@ -164,7 +170,7 @@ After installation, the system administrator should generate keys using
 (define-public heimdal
   (package
     (name "heimdal")
-    (version "7.5.0")
+    (version "7.7.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -172,14 +178,14 @@ After installation, the system administrator should generate keys using
                     "heimdal-" version "/" "heimdal-" version ".tar.gz"))
               (sha256
                (base32
-                "1bdc682in55ygrxmhncs7cf4s239apcblci3z8i80wnc1w1s18n5"))
+                "06vx3cb01s4lv3lpv0qzbbj97cln1np1wjphkkmmbk1lsqa36bgh"))
               (modules '((guix build utils)))
               (snippet
                '(begin
                   (substitute* "configure"
                     (("User=.*$") "User=Guix\n")
                     (("Host=.*$") "Host=GNU")
-                    (("Date=.*$") "Date=2017\n"))
+                    (("Date=.*$") "Date=2019\n"))
                   #t))))
     (build-system gnu-build-system)
     (arguments