Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / package-management.scm
index 9865c1c..a61a079 100644 (file)
@@ -165,7 +165,7 @@ the Nix package manager.")
   ;;
   ;; Note: use a short commit id; when using the long one, the limit on socket
   ;; file names is exceeded while running the tests.
-  (let ((commit "684bf7c"))
+  (let ((commit "dd91141"))
     (package (inherit guix-0.8.2)
       (version (string-append "0.8.2." commit))
       (source (origin
@@ -175,21 +175,32 @@ the Nix package manager.")
                       (commit commit)))
                 (sha256
                  (base32
-                  "0fq9ajj17kbb0f1p79al2vcqah9sl0imayhggcp31c3vq0ahya9g"))
+                  "05rgz1kkxjsc07asvwrf6gpjc8blpvs5ipbby4kvjjq6j0g2bgxa"))
                 (file-name (string-append "guix-" version "-checkout"))))
       (arguments
        (substitute-keyword-arguments (package-arguments guix-0.8.2)
          ((#:phases phases)
-          `(alist-cons-after
-            'unpack 'bootstrap
-            (lambda _
-              ;; Make sure 'msgmerge' can modify the PO files.
-              (for-each (lambda (po)
-                          (chmod po #o666))
-                        (find-files "." "\\.po$"))
+          `(modify-phases ,phases
+             (add-after
+              'unpack 'bootstrap
+              (lambda _
+                ;; Make sure 'msgmerge' can modify the PO files.
+                (for-each (lambda (po)
+                            (chmod po #o666))
+                          (find-files "." "\\.po$"))
 
-              (zero? (system* "sh" "bootstrap")))
-            ,phases))))
+                (zero? (system* "sh" "bootstrap"))))
+             (add-after
+              'unpack 'disable-container-tests
+              ;; XXX FIXME: These tests fail within the build container.
+              (lambda _
+                (substitute* "tests/syscalls.scm"
+                  (("^\\(test-assert \"(clone|setns|pivot-root)\"" all)
+                   (string-append "(test-skip 1)\n" all)))
+                (substitute* "tests/containers.scm"
+                  (("^\\(test-assert" all)
+                   (string-append "(test-skip 1)\n" all)))
+                #t))))))
       (native-inputs
        `(("autoconf" ,(autoconf-wrapper))
          ("automake" ,automake)