gnu: googletest: Update to 1.10.0.
[jackhill/guix/guix.git] / gnu / packages / gcal.scm
index d6adc80..32d3849 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2018 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public gcal
   (package
     (name "gcal")
-    (version "3.6.3")
+    (version "4.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gcal/gcal-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "06xkwkir9w4jd9i72m1izmf4rbry4slg8gkiml4w26h13lx92hk7"))))
+               "1av11zkfirbixn05hyq4xvilin0ncddfjqzc4zd9pviyp506rdci"))
+             (modules '((guix build utils)))
+             (snippet
+              '(begin
+                 ;; Adjust the bundled gnulib to work with glibc 2.28.  See e.g.
+                 ;; "m4-gnulib-libio.patch".  This is a phase rather than patch
+                 ;; or snippet to work around <https://bugs.gnu.org/32347>.
+                 (substitute* (find-files "lib" "\\.c$")
+                   (("#if defined _IO_ftrylockfile")
+                    "#if defined _IO_EOF_SEEN"))
+                 (substitute* "lib/stdio-impl.h"
+                   (("^/\\* BSD stdio derived implementations")
+                    (string-append "#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN\n"
+                                   "# define _IO_IN_BACKUP 0x100\n"
+                                   "#endif\n\n"
+                                   "/* BSD stdio derived implementations")))
+                 #t))))
     (build-system gnu-build-system)
-    (home-page "http://www.gnu.org/software/gcal")
+    (home-page "https://www.gnu.org/software/gcal/")
     (synopsis "Calculating and printing a wide variety of calendars")
     (description
-     "Gcal is a program for calculating and printing calendars.  Gcal displays
-hybrid and proleptic Julian and Gregorian calendar sheets,respectively for one
-month, three months, or a whole year.  It also displays eternal holiday lists
-for many countries around the globe, and features a very powerful creation of
-fixed date lists that can be used for reminding purposes.  Gcal can calculate
-various astronomical data and times of the Sun and the Moon for pleasure at
-any location, precisely enough for most civil purposes.  Gcal supports some
-other calendar systems, for example, the Chinese and Japanese calendars, the
-Hebrew calendar, and the civil Islamic calendar, too.")
+     "Gcal is a program to calculate and print calendars on the
+command-line.  Calendars can be printed in 1-month, 3-month or whole-year
+views.  In addition, eternal holiday lists can be generated for many
+countries, which can be complemented by user-made lists of fixed dates to
+make an agenda.  Gcal can also calculate astronomical data, such as the
+phases of the moon, and supports alternative calendar formats: Julian,
+Gregorian, Islamic, Chinese and more.")
     (license gpl3+)))