gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / compton.scm
index dec9a94..2a5f3bf 100644 (file)
@@ -1,5 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
+;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-module (gnu packages compton)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
-  #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system meson)
+  #:use-module (gnu packages datastructures)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages documentation)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages libevent)
+  #:use-module (gnu packages pcre)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages textutils)
       (name "compton")
       (version (string-filter (char-set-complement (char-set #\_))
                               upstream-version))
-      (source (origin
-                (method url-fetch)
-                (uri (string-append
-                      "https://github.com/chjj/" name "/archive/v"
-                      upstream-version ".tar.gz"))
-                (sha256
-                 (base32
-                  "02dhlqqcwnmlf2dxg7rd4lapgqahgndzixdkbpxicq9jawmdb73v"))
-                (file-name (string-append name "-" version "-checkout"))))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/chjj/compton")
+               (commit (string-append "v" upstream-version))))
+         (sha256
+          (base32
+           "0v65viilhnd2xgvmdpzc1srxszcg8kj1vhi5gy9292j48w0s2fx1"))
+         (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (inputs
        `(("dbus" ,dbus)
@@ -101,3 +110,50 @@ performance).
 @item Some more options...
 @end itemize\n")
       (license license:expat))))
+
+(define-public picom
+  (package
+    (name "picom")
+    (version "8.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/yshui/picom")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32
+         "0gjksayz2xpmgglvw17ppsan2imrd1fijs579kbf27xwp503xgfl"))
+       (file-name (string-append "picom-" version))))
+    (build-system meson-build-system)
+    (inputs
+     `(("dbus" ,dbus)
+       ("libconfig" ,libconfig)
+       ("libx11" ,libx11)
+       ("libxext" ,libxext)
+       ("libev" ,libev)
+       ("mesa" ,mesa)
+       ("xprop" ,xprop)
+       ("xcb-util-renderutil" ,xcb-util-renderutil)
+       ("xcb-util-image" ,xcb-util-image)
+       ("pixman" ,pixman)
+       ("uthash" ,uthash)
+       ("libxdg-basedir" ,libxdg-basedir)
+       ("pcre" ,pcre)))
+    (native-inputs
+     `(("asciidoc" ,asciidoc)
+       ("pkg-config" ,pkg-config)
+       ("xorgproto" ,xorgproto)))
+    (arguments
+     `(#:build-type "release"
+       #:configure-flags '("-Dwith_docs=true")))
+    (home-page "https://github.com/yshui/picom")
+    (synopsis "Compositor for X11, forked from Compton")
+    (description
+     "Picom is a standalone compositor for Xorg, suitable for use
+with window managers that do not provide compositing.
+
+Picom is a fork of compton, which is a fork of xcompmgr-dana,
+which in turn is a fork of xcompmgr.")
+    (license (list license:expat      ; The original compton license.
+                   license:mpl2.0)))) ; License used by new picom files.