gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / gcc.scm
index bba3590..571526e 100644 (file)
@@ -23,6 +23,7 @@
   #:use-module (gnu packages bootstrap)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages multiprecision)
+  #:use-module (gnu packages texinfo)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
@@ -104,6 +105,10 @@ where the OS part is overloaded to denote a specific ABI---into GCC
                 ("cloog" ,cloog)
                 ("libelf" ,libelf)
                 ("zlib" ,zlib)))
+
+      ;; GCC is one of the few packages that doesn't ship .info files.
+      (native-inputs `(("texinfo" ,texinfo)))
+
       (arguments
        `(#:out-of-source? #t
          #:strip-binaries? ,stripped?
@@ -199,16 +204,15 @@ used in the GNU system including the GNU/Linux variant.")
       (home-page "http://gcc.gnu.org/"))))
 
 (define-public gcc-4.8
-  ;; FIXME: Move to gcc.scm when Binutils is updated.
   (package (inherit gcc-4.7)
-    (version "4.8.0")
+    (version "4.8.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gcc/gcc-"
                                  version "/gcc-" version ".tar.bz2"))
              (sha256
               (base32
-               "0b6cp9d1sas3vq6dj3zrgd134p9b569fqhbixb9cl7mp698zwdxh"))))))
+               "04sqn0ds17ys8l6zn7vyyvjz1a7hsk4zb0381vlw9wnr7az48nsl"))))))
 
 (define-public isl
   (package