Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / text-editors.scm
index 06e8e47..2536754 100644 (file)
@@ -239,14 +239,16 @@ Wordstar-, EMACS-, Pico, Nedit or vi-like key bindings.  e3 can be used on
 (define-public mg
   (package
     (name "mg")
-    (version "20171014")
+    (version "20180408")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://homepage.boetes.org/software/mg/mg-"
-                                  version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/hboetes/mg")
+                    (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "0hakfikzsml7z0hja8m8mcahrmfy2piy81bq9nccsjplyfc9clai"))
+                "06w86xk7sjl2x2h3z6msn8kpmwj05qdimcym77wzhz5s94dzh1bl"))
               (modules '((guix build utils)))
               (snippet '(begin
                           (substitute* "GNUmakefile"
@@ -262,10 +264,9 @@ Wordstar-, EMACS-, Pico, Nedit or vi-like key bindings.  e3 can be used on
      ;; No test suite available.
      '(#:tests? #f
        #:make-flags (list (string-append "prefix=" %output)
-                          "CURSES_LIBS=-lncurses"
                           "CC=gcc")
        #:phases (modify-phases %standard-phases
-                  (delete 'configure)
+                  (delete 'configure)   ; no configure script
                   (add-before 'build 'correct-location-of-difftool
                     (lambda _
                       (substitute* "buffer.c"
@@ -294,7 +295,7 @@ team.")
 (define-public ghostwriter
   (package
     (name "ghostwriter")
-    (version "1.6.1")
+    (version "1.6.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -303,7 +304,7 @@ team.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1ihdr4xk0j83q83xknbikxb7yf9qhlkgvc89w33lhj090cv376gd"))))
+                "0251563zy0q69fzfacvalpx43y15cshb0bhshyd4w37061gh1c12"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)