gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / ghostscript.scm
index 6781ffe..dd6c576 100644 (file)
@@ -27,7 +27,6 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages tcl)
-  #:use-module (gnu packages xorg)
   #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -135,8 +134,6 @@ printing, and psresize, for adjusting page sizes.")
              ("libpng" ,libpng)
              ("libpaper" ,libpaper)
              ("libtiff" ,libtiff)
-             ("libxext" ,libxext)
-             ("libxt" ,libxt)
              ("perl" ,perl)
              ("pkg-config" ,pkg-config) ; needed to find libtiff
              ("python" ,python)
@@ -217,28 +214,23 @@ Ghostscript. It currently includes the 35 standard PostScript fonts.")
    (license license:gpl2)
    (home-page "http://sourceforge.net/projects/gs-fonts/")))
 
-(define-public gv
+(define-public libspectre
   (package
-   (name "gv")
-   (version "3.7.4")
+   (name "libspectre")
+   (version "0.2.7")
    (source (origin
             (method url-fetch)
-            (uri (string-append "mirror://gnu/gv/gv-"
+            (uri (string-append "http://libspectre.freedesktop.org/releases/libspectre-"
                                 version ".tar.gz"))
             (sha256 (base32
-                     "0q8s43z14vxm41pfa8s5h9kyyzk1fkwjhkiwbf2x70alm6rv6qi1"))))
+                     "1v63lqc6bhhxwkpa43qmz8phqs8ci4dhzizyy16d3vkb20m846z8"))))
    (build-system gnu-build-system)
-   (propagated-inputs `(("ghostscript" ,ghostscript)))
-   (inputs `(("libx11" ,libx11)
-             ("libxaw3d" ,libxaw3d)
-             ("libxinerama" ,libxinerama)
-             ("libxpm" ,libxpm)
-             ("pkg-config" ,pkg-config)
-             ("zlib" ,zlib)))
-   (synopsis "postscript and pdf viewer for x")
+   (inputs `(("ghostscript" ,ghostscript)
+             ("pkg-config" ,pkg-config)))
+   (synopsis "postscript rendering library")
    (description
-    "GNU gv allows to view and navigate through PostScript and PDF documents
-on an X display by providing a graphical user interface for the Ghostscript
-interpreter.")
-   (license license:gpl3+)
-   (home-page "http://www.gnu.org/software/gv/")))
+    "libspectre is a small library for rendering Postscript documents.
+It provides a convenient easy to use API for handling and rendering
+Postscript documents.")
+   (license license:gpl2+)
+   (home-page "http://www.freedesktop.org/wiki/Software/libspectre")))