gnu: Add LV2 mda Piano plugin.
[jackhill/guix/guix.git] / gnu / packages / texlive.scm
index b136c99..e332140 100644 (file)
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -18,8 +19,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages texlive)
-  #:use-module ((guix licenses)
-                #:renamer (symbol-prefix-proc 'license:))
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages pdf)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
-  #:use-module (gnu packages which)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages ruby)
   #:use-module (gnu packages tcsh)
+  #:use-module (gnu packages which)
   #:use-module (gnu packages xorg)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages zip)
   #:autoload   (gnu packages texinfo) (texinfo))
 
              ("texlive-texmf-src" ,texlive-texmf-src)
              ("cairo" ,cairo)
              ("fontconfig" ,fontconfig)
+             ("fontforge" ,fontforge)
              ("freetype" ,freetype)
              ("gd" ,gd)
-             ("icu4c" ,icu4c)
              ("ghostscript" ,ghostscript)
+             ("graphite2" ,graphite2)
+             ("harfbuzz" ,harfbuzz)
+             ("icu4c" ,icu4c)
+             ("libpaper" ,libpaper)
              ("libpng" ,libpng)
              ("libxaw" ,libxaw)
              ("libxt" ,libxt)
+             ("perl" ,perl)
              ("pixman" ,pixman)
              ("poppler" ,poppler)
-             ;; FIXME: Add interpreters fontforge and ruby,
-             ;; once they are available.
+             ("potrace" ,potrace)
+             ("python" ,python-2) ; incompatible with Python 3 (print syntax)
+             ("ruby" ,ruby)
+             ("tcsh" ,tcsh)
              ("teckit" ,teckit)
-             ("t1lib" ,t1lib)
              ("zlib" ,zlib)
              ("zziplib" ,zziplib)))
    (native-inputs
-    `(("perl" ,perl)
-      ("pkg-config" ,pkg-config)
-      ("python" ,python-2) ; incompatible with Python 3 (print syntax)
-      ("tcsh" ,tcsh)))
+    `(("pkg-config" ,pkg-config)))
    (outputs '("out" "data"))
    (arguments
     `(#:out-of-source? #t
          "--with-system-cairo"
          "--with-system-freetype2"
          "--with-system-gd"
-         ;; "--with-system-graphite2"  ; requires cmake build system
-         ;; "--with-system-harfbuzz"   ; requires --with-system-graphite2
+         "--with-system-graphite2"
+         "--with-system-harfbuzz"
          "--with-system-icu"
          "--with-system-libgs"
+         "--with-system-libpaper"
          "--with-system-libpng"
          "--with-system-pixman"
          "--with-system-poppler"
-         "--with-system-t1lib"
+         "--with-system-potrace"
          "--with-system-teckit"
          "--with-system-xpdf"
          "--with-system-zlib"
          "--with-system-zziplib")
+
+      ;; Disable tests on mips64 to cope with a failure of luajiterr.test.
+      ;; XXX FIXME fix luajit properly on mips64.
+      #:tests? ,(not (string-prefix? "mips64" (or (%current-target-system)
+                                                  (%current-system))))
       #:phases
        (alist-cons-after
         'install 'postinst
@@ -200,7 +211,7 @@ world.")
               ("python" ,python-2) ; incompatible with Python 3 (print syntax)
               ("which" ,which)))
     (home-page "https://launchpad.net/rubber")
-    (synopsis "Rubber, a wrapper for LaTeX and friends")
+    (synopsis "Wrapper for LaTeX and friends")
     (description
      "Rubber is a program whose purpose is to handle all tasks related to the
 compilation of LaTeX documents.  This includes compiling the document itself,