gnu: miniupnpc: Update to 2.0.
[jackhill/guix/guix.git] / gnu / packages / assembly.scm
index c80b8af..29ccf1f 100644 (file)
@@ -25,6 +25,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (gnu packages)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages python)
@@ -104,6 +105,7 @@ debugging information in STABS, DWARF 2, and CodeView 8 formats.")
               (base32
                "19j9nwl88k660045s40cbz5zrl1wpd2mcxnnc8qqnnaj311a58qz"))))
     (build-system gnu-build-system)
+    (native-inputs `(("zlib" ,zlib)))
     (synopsis "Library for generating assembly code at runtime")
     (description
      "GNU Lightning is a library that generates assembly language code at
@@ -111,4 +113,4 @@ run-time.  Thus, it is useful in creating Just-In-Time compilers.  It
 abstracts over the target CPU by exposing a standardized RISC instruction set
 to the clients.")
     (home-page "http://www.gnu.org/software/lightning/")
-    (license gpl3+)))
+    (license license:gpl3+)))