Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / pretty-print.scm
index 07837eb..8ba9780 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
                           version ".tar.gz"))
       (sha256
        (base32
-        "195k78m1h03m961qn7jr120z815iyb93gwi159p1p9348lyqvbpk"))))
+        "195k78m1h03m961qn7jr120z815iyb93gwi159p1p9348lyqvbpk"))
+      (patches (search-patches
+                 "a2ps-CVE-2001-1593.patch"
+                 "a2ps-CVE-2014-0466.patch"))))
     (build-system gnu-build-system)
     (inputs
      `(("psutils" ,psutils)
      `(("gperf" ,gperf)
        ("perl" ,perl)))
     (arguments
-     '(#:phases (alist-cons-before
-                 'build 'patch-scripts
-                 (lambda _
-                   (substitute*
-                       '("afm/make_fonts_map.sh"
-                         "tests/defs"
-                         "tests/backup.tst"
-                         "tests/styles.tst")
-                     (("/bin/rm") (which "rm"))))
-                 (alist-cons-before
-                  'check 'patch-test-files
-                  ;; Alternatively, we could unpatch the shebangs in tstfiles
-                  (lambda* (#:key inputs #:allow-other-keys)
-                    (let ((perl (assoc-ref inputs "perl")))
-                      (substitute* '("tests/ps-ref/includeres.ps"
-                                     "tests/gps-ref/includeres.ps")
-                        (("/usr/local/bin/perl")
-                         (string-append perl "/bin/perl"))))
-                    ;; Some of the reference postscript contain a 'version 3'
-                    ;; string that in inconsistent with the source text in the
-                    ;; tstfiles directory.  Erroneous search-and-replace?
-                    (substitute* '("tests/ps-ref/InsertBlock.ps"
-                                   "tests/gps-ref/InsertBlock.ps"
-                                   "tests/ps-ref/bookie.ps"
-                                   "tests/gps-ref/bookie.ps")
-                      (("version 3") "version 2"))
-                    (substitute* '("tests/ps-ref/psmandup.ps"
-                                   "tests/gps-ref/psmandup.ps")
-                      (("#! */bin/sh") (string-append
-                                        "#!" (which "sh")))))
-                  %standard-phases))))
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'patch-scripts
+           (lambda _
+             (substitute*
+                 '("afm/make_fonts_map.sh"
+                   "tests/defs"
+                   "tests/backup.tst"
+                   "tests/styles.tst")
+               (("/bin/rm") (which "rm")))))
+         (add-before 'check 'patch-test-files
+           ;; Alternatively, we could unpatch the shebangs in tstfiles
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((perl (assoc-ref inputs "perl")))
+               (substitute* '("tests/ps-ref/includeres.ps"
+                              "tests/gps-ref/includeres.ps")
+                 (("/usr/local/bin/perl")
+                  (string-append perl "/bin/perl"))))
+             ;; Some of the reference postscript contain a 'version 3'
+             ;; string that in inconsistent with the source text in the
+             ;; tstfiles directory.  Erroneous search-and-replace?
+             (substitute* '("tests/ps-ref/InsertBlock.ps"
+                            "tests/gps-ref/InsertBlock.ps"
+                            "tests/ps-ref/bookie.ps"
+                            "tests/gps-ref/bookie.ps")
+               (("version 3") "version 2"))
+             (substitute* '("tests/ps-ref/psmandup.ps"
+                            "tests/gps-ref/psmandup.ps")
+               (("#! */bin/sh") (string-append
+                                 "#!" (which "sh")))))))))
     (home-page "http://www.gnu.org/software/a2ps")
     (synopsis "Any file to PostScript, including pretty-printing")
     (description
      "GNU a2ps converts almost anything to a PostScript file, ready for
-printing. It accomplishes this by being able to delegate files to external
+printing.  It accomplishes this by being able to delegate files to external
 handlers, such as Groff and Gzip.  It handles as many steps as is necessary to
 produce a pretty-printed file.  It also includes some extra abilities for
 special cases, such as pretty-printing \"--help\" output.")
@@ -136,7 +139,7 @@ indentation counting, function and file indices and more.")
     (synopsis "Generating PostScript, including pretty-printing")
     (description
      "GNU Enscript is a program to convert ASCII text files to PostScript,
-HTML or RTF formats, to be stored in files or sent immediately to a printer. 
+HTML or RTF formats, to be stored in files or sent immediately to a printer.
 It also includes the capability to perform syntax highlighting for several
 different programming languages.")
     (license gpl3+)))
@@ -144,7 +147,7 @@ different programming languages.")
 (define-public source-highlight
   (package
     (name "source-highlight")
-    (version "3.1.7")
+    (version "3.1.8")
     (source
      (origin
       (method url-fetch)
@@ -152,11 +155,7 @@ different programming languages.")
                           version ".tar.gz"))
       (sha256
        (base32
-        "1s49ld8cnpzhhwq0r7s0sfm3cg3nhhm0wla27lwraifrrl3y1cp1"))
-      (patches
-       (list (search-patch
-              ;; Patch submitted as Savannah item #41786
-              "source-highlight-regexrange-test.patch")))))
+        "18xdalxg7yzrxc1njzgw7aryq2jdm7zq2yqz41sc7k6il5z6lcq1"))))
     (build-system gnu-build-system)
     ;; The ctags that comes with emacs does not support the --excmd options,
     ;; so can't be used
@@ -195,4 +194,46 @@ their syntactic role.  It supports over 150 different languages and it can
 output to 8 different formats, including HTML, LaTeX and ODF.  It can also
 output to ANSI color escape sequences, so that highlighted source code can be
 seen in a terminal.")
-    (license gpl3+)))
+    (license gpl3+)
+    (properties '((ftp-directory . "/gnu/src-highlite")))))
+
+(define-public astyle
+  (package
+    (name "astyle")
+    (version "2.05")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/astyle/astyle/astyle%20"
+                           version "/astyle_"  version "_linux.tar.gz"))
+       (sha256
+        (base32
+         "0f9sh9kq5ajp1yz133h00fr9235p1m698x7n3h7zbrhjiwgynd6s"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ;no tests
+       #:make-flags (list (string-append "prefix=" %output)
+                          "INSTALL=install"
+                          "all")
+       #:phases (alist-replace
+                 'configure
+                 (lambda _ (chdir "build/gcc"))
+                 (alist-cons-after
+                  'install 'install-libs
+                  (lambda* (#:key outputs #:allow-other-keys)
+                    ;; Libraries are not installed by default
+                    (let* ((output (assoc-ref outputs "out"))
+                           (libdir (string-append output "/lib")))
+                      (begin
+                        (mkdir-p libdir)
+                        (for-each (lambda (l)
+                                    (copy-file
+                                     l (string-append libdir "/" (basename l))))
+                                  (find-files "bin" "lib*")))))
+                  %standard-phases))))
+    (home-page "http://astyle.sourceforge.net/")
+    (synopsis "Source code indenter, formatter, and beautifier")
+    (description
+     "Artistic Style is a source code indenter, formatter, and beautifier for
+the C, C++, C++/CLI, Objective‑C, C#, and Java programming languages.")
+    (license lgpl3+)))