gnu: Move more web packages from python.scm to python-web.scm.
[jackhill/guix/guix.git] / gnu / packages / cran.scm
index ce46dcc..8121e03 100644 (file)
@@ -23,6 +23,7 @@
   #:use-module (guix utils)
   #:use-module (guix build-system r)
   #:use-module (gnu packages gcc)
+  #:use-module (gnu packages machine-learning)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages statistics)
@@ -51,14 +52,14 @@ colors are provided.")
 (define-public r-glue
   (package
     (name "r-glue")
-    (version "1.1.1")
+    (version "1.2.0")
     (source
      (origin
        (method url-fetch)
        (uri (cran-uri "glue" version))
        (sha256
         (base32
-         "01awmqby7rwzhzr51m7d87wqibx7ggl6xair8fi3z3q1hkyyv7ih"))))
+         "0vi9y8ix95g6hjqdz9c9y4119apbdjcypdv0ag8cl6vaxqs5n9qr"))))
     (build-system r-build-system)
     (home-page "https://github.com/tidyverse/glue")
     (synopsis "Interpreted string literals")
@@ -91,13 +92,13 @@ error stream.")
 (define-public r-rcpp
   (package
     (name "r-rcpp")
-    (version "0.12.12")
+    (version "0.12.13")
     (source
      (origin
        (method url-fetch)
        (uri (cran-uri "Rcpp" version))
        (sha256
-        (base32 "1byyqvlgb2p46p1gv243k73rk69fa8pa4l5m5asmckag2pkb2glz"))))
+        (base32 "1bm84yc48475plgsnnbvzi6nzkixpnfw8ry86ax63f9g524asw55"))))
     (build-system r-build-system)
     (home-page "http://www.rcpp.org")
     (synopsis "Seamless R and C++ integration")
@@ -409,6 +410,8 @@ any subsequent lookup as it keeps the hash table in memory.")
      "This package provides data structures that are stored on disk but
 behave (almost) as if they were in RAM by transparently mapping only a section
 in main memory.")
+    ;; error Architecture not supported.
+    (supported-systems (delete "aarch64-linux" %supported-systems))
     (license license:gpl2)))
 
 (define-public r-ffbase
@@ -536,14 +539,14 @@ plot networks.")
 (define-public r-proxy
   (package
     (name "r-proxy")
-    (version "0.4-17")
+    (version "0.4-19")
     (source
      (origin
        (method url-fetch)
        (uri (cran-uri "proxy" version))
        (sha256
         (base32
-         "0bg1fn96qrj8whmnl7c3gv244ksm2ykxxsd0zrmw4lb6465pizl2"))))
+         "0ladwgi70jw2a3adgg2xadw8hz3mm6llsw428c1fcrl305sy49vb"))))
     (build-system r-build-system)
     (home-page "http://cran.r-project.org/web/packages/proxy")
     (synopsis "Distance and similarity measures")
@@ -556,14 +559,14 @@ most popular ones.")
 (define-public r-sp
   (package
     (name "r-sp")
-    (version "1.2-4")
+    (version "1.2-5")
     (source
      (origin
        (method url-fetch)
        (uri (cran-uri "sp" version))
        (sha256
         (base32
-         "0crba3j00mb2xv2yk60rpa57gn97xq4ql3a6p9cjzqjxzv2cknk2"))))
+         "09yydnacp33yx0kn537k96fjlbf75fjafqfknpa5gvci4l888bqd"))))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-lattice" ,r-lattice)))
@@ -623,14 +626,14 @@ quantile mixture from L-moments and trimmed L-moments.")
 (define-public r-distillery
   (package
     (name "r-distillery")
-    (version "1.0-2")
+    (version "1.0-4")
     (source
      (origin
        (method url-fetch)
        (uri (cran-uri "distillery" version))
        (sha256
         (base32
-         "12m4cacvc18fd3aayc8iih5q6bwsmvf29b55fwp7vs8wp1h8nd8c"))))
+         "1m0pgmlvk7bsb6q3kxagnq422babk61sf73naavac68v8x2q8fix"))))
     (build-system r-build-system)
     (home-page "http://www.ral.ucar.edu/staff/ericg")
     (synopsis "Functions for confidence intervals and object information")
@@ -714,14 +717,14 @@ and S4 methods with inlined C, C++ or Fortran code supporting @code{.C} and
 (define-public r-bbmle
   (package
     (name "r-bbmle")
-    (version "1.0.19")
+    (version "1.0.20")
     (source
      (origin
        (method url-fetch)
        (uri (cran-uri "bbmle" version))
        (sha256
         (base32
-         "014h6mw16gv4acs2p78dy7lla7s428n633aybsb1mbi6250dg0p8"))))
+         "1xzij7swrrzl5ly8l3lw6awh486zcm00251dwqws1y23fbgyh3vc"))))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-lattice" ,r-lattice)
@@ -851,14 +854,14 @@ data).  Weighted versions of MLE, MME and QME are available.")
 (define-public r-energy
   (package
     (name "r-energy")
-    (version "1.7-0")
+    (version "1.7-2")
     (source
      (origin
        (method url-fetch)
        (uri (cran-uri "energy" version))
        (sha256
         (base32
-         "1g4hqi6mgsnd1w4q7dd2m40ljh2jdmvad91ksbq9fscnrqpvji1x"))))
+         "19c7bgjnm4ggf7w5mk64c5shkma3sa9wc8x117iqv7pk1bvvyy3p"))))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-boot" ,r-boot)
@@ -904,14 +907,14 @@ George Marsaglia are included.")
 (define-public r-ksamples
   (package
     (name "r-ksamples")
-    (version "1.2-6")
+    (version "1.2-7")
     (source
      (origin
        (method url-fetch)
        (uri (cran-uri "kSamples" version))
        (sha256
         (base32
-         "1pbam0zqq44slpxdgl2s2fsfdgl7i0pgm8bzlvnm0fy0na24bgdj"))))
+         "0f19rjngk0lg6s8c6h5l55qpxp8sl4vxj3kpi05cizzncny9b9bj"))))
     (properties `((upstream-name . "kSamples")))
     (build-system r-build-system)
     (propagated-inputs
@@ -928,3 +931,645 @@ sampling from populations, given the observed tie pattern.  Except for Steel's
 test and the JT test it also combines these tests across several blocks of
 samples.")
     (license license:gpl2+)))
+
+(define-public r-cvst
+  (package
+    (name "r-cvst")
+    (version "0.2-1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "CVST" version))
+       (sha256
+        (base32
+         "17xacyi8cf37rr2xswx96qy7pwkaqq394awdlswykz3qlyzx4zx2"))))
+    (properties `((upstream-name . "CVST")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-kernlab" ,r-kernlab)
+       ("r-matrix" ,r-matrix)))
+    (home-page "http://cran.r-project.org/web/packages/CVST")
+    (synopsis "Fast cross-validation via sequential testing")
+    (description
+     "This package implements the fast cross-validation via sequential
+testing (CVST) procedure.  CVST is an improved cross-validation procedure
+which uses non-parametric testing coupled with sequential analysis to
+determine the best parameter set on linearly increasing subsets of the data.
+Additionally to the CVST the package contains an implementation of the
+ordinary k-fold cross-validation with a flexible and powerful set of helper
+objects and methods to handle the overall model selection process.  The
+implementations of the Cochran's Q test with permutations and the sequential
+testing framework of Wald are generic and can therefore also be used in other
+contexts.")
+    (license license:gpl2+)))
+
+(define-public r-lava
+  (package
+    (name "r-lava")
+    (version "1.5.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "lava" version))
+       (sha256
+        (base32
+         "1vcm04h9i39gmf2prl5d4j4il4gs6skzr6y2fvl1vn4hklna87f4"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-numderiv" ,r-numderiv)
+       ("r-survival" ,r-survival)))
+    (home-page "https://github.com/kkholst/lava")
+    (synopsis "Latent variable models")
+    (description
+     "This package provides tools for the estimation and simulation of latent
+variable models.")
+    (license license:gpl3)))
+
+(define-public r-drr
+  (package
+    (name "r-drr")
+    (version "0.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "DRR" version))
+       (sha256
+        (base32
+         "1scfwp6ry6apxzqjclsmn2frxp9qfw6zxsxn5w0j0q3sz42hz1h2"))))
+    (properties `((upstream-name . "DRR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-cvst" ,r-cvst)
+       ("r-kernlab" ,r-kernlab)
+       ("r-matrix" ,r-matrix)))
+    (home-page "http://cran.r-project.org/web/packages/DRR")
+    (synopsis "Dimensionality reduction via regression")
+    (description
+     "This package provides an implementation of dimensionality reduction via
+regression using Kernel Ridge Regression.")
+    (license license:gpl3)))
+
+(define-public r-prodlim
+  (package
+    (name "r-prodlim")
+    (version "1.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "prodlim" version))
+       (sha256
+        (base32
+         "0m51rkivx1zr6whdqwj66jpnkmp4385m06kkha3dp8qqf4jna9iz"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-kernsmooth" ,r-kernsmooth)
+       ("r-lava" ,r-lava)
+       ("r-rcpp" ,r-rcpp)
+       ("r-survival" ,r-survival)))
+    (home-page "http://cran.r-project.org/web/packages/prodlim")
+    (synopsis "Product-limit estimation for censored event history analysis")
+    (description
+     "This package provides a fast and user-friendly implementation of
+nonparametric estimators for censored event history (survival) analysis with
+the Kaplan-Meier and Aalen-Johansen methods.")
+    (license license:gpl2+)))
+
+(define-public r-dimred
+  (package
+    (name "r-dimred")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "dimRed" version))
+       (sha256
+        (base32
+         "0fasca5fsbrxdwv30hch7vb9snb844l7l8p5fjf239dq45xfy37v"))))
+    (properties `((upstream-name . "dimRed")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-drr" ,r-drr)))
+    (home-page "https://github.com/gdkrmr/dimRed")
+    (synopsis "Framework for dimensionality reduction")
+    (description
+     "This package provides a collection of dimensionality reduction
+techniques from R packages and provides a common interface for calling the
+methods.")
+    (license license:gpl3)))
+
+(define-public r-timedate
+  (package
+    (name "r-timedate")
+    (version "3012.100")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "timeDate" version))
+       (sha256
+        (base32
+         "0cn4h23y2y2bbg62qgm79xx4cvfla5xbpmi9hbdvkvpmm5yfyqk2"))))
+    (properties `((upstream-name . "timeDate")))
+    (build-system r-build-system)
+    (home-page "https://www.rmetrics.org")
+    (synopsis "Chronological and calendar objects")
+    (description
+     "This package provides an environment for teaching \"Financial
+Engineering and Computational Finance\" and for managing chronological and
+calendar objects.")
+    (license license:gpl2+)))
+
+(define-public r-ddalpha
+  (package
+    (name "r-ddalpha")
+    (version "1.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ddalpha" version))
+       (sha256
+        (base32
+         "0pczw9543y7f92m7gyk7rxcjn8vsjaldc5vl0r56ywip9i374zbh"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bh" ,r-bh)
+       ("r-class" ,r-class)
+       ("r-mass" ,r-mass)
+       ("r-rcpp" ,r-rcpp)
+       ("r-robustbase" ,r-robustbase)
+       ("r-sfsmisc" ,r-sfsmisc)))
+    (native-inputs
+     `(("gfortran" ,gfortran)))
+    (home-page "http://cran.r-project.org/web/packages/ddalpha")
+    (synopsis "Depth-Based classification and calculation of data depth")
+    (description
+     "This package contains procedures for depth-based supervised learning,
+which are entirely non-parametric, in particular the DDalpha-procedure (Lange,
+Mosler and Mozharovskyi, 2014).  The training data sample is transformed by a
+statistical depth function to a compact low-dimensional space, where the final
+classification is done.  It also offers an extension to functional data and
+routines for calculating certain notions of statistical depth functions.  50
+multivariate and 5 functional classification problems are included.")
+    (license license:gpl2)))
+
+(define-public r-gower
+  (package
+    (name "r-gower")
+    (version "0.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "gower" version))
+       (sha256
+        (base32
+         "1mbrj1lam3jfbby2j32shmmj5cn09zx3rkxbamq7q8sdg39b54gb"))))
+    (build-system r-build-system)
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/markvanderloo/gower")
+    (synopsis "Gower's distance")
+    (description
+     "This package provides tools to compute Gower's distance (or similarity)
+coefficient between records, and to compute the top-n matches between records.
+Core algorithms are executed in parallel on systems supporting OpenMP.")
+    (license license:gpl3)))
+
+(define-public r-rcpproll
+  (package
+    (name "r-rcpproll")
+    (version "0.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "RcppRoll" version))
+       (sha256
+        (base32
+         "19xzvxym8zbighndygkq4imfwc0abh4hqyq3qrr8aakyd096iisi"))))
+    (properties `((upstream-name . "RcppRoll")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-rcpp" ,r-rcpp)))
+    (home-page "http://cran.r-project.org/web/packages/RcppRoll")
+    (synopsis "Efficient rolling and windowed operations")
+    (description
+     "This package provides fast and efficient routines for common rolling /
+windowed operations.  Routines for the efficient computation of windowed mean,
+median, sum, product, minimum, maximum, standard deviation and variance are
+provided.")
+    (license license:gpl2+)))
+
+(define-public r-ipred
+  (package
+    (name "r-ipred")
+    (version "0.9-6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ipred" version))
+       (sha256
+        (base32
+         "1vrw1pqcpnc04x1r2h9grdfm6bivs358sww5gg90jwlvxcw69lxq"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-class" ,r-class)
+       ("r-mass" ,r-mass)
+       ("r-nnet" ,r-nnet)
+       ("r-prodlim" ,r-prodlim)
+       ("r-rpart" ,r-rpart)
+       ("r-survival" ,r-survival)))
+    (home-page "http://cran.r-project.org/web/packages/ipred")
+    (synopsis "Improved predictors")
+    (description
+     "This package provides improved predictive models by indirect
+classification and bagging for classification, regression and survival
+problems as well as resampling based estimators of prediction error.")
+    (license license:gpl2+)))
+
+(define-public r-recipes
+  (package
+    (name "r-recipes")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "recipes" version))
+       (sha256
+        (base32
+         "0rydk403qihxmcv3zz323r3ywk4g1v7ibvj452rxhm0z22sqk9kb"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ddalpha" ,r-ddalpha)
+       ("r-dimred" ,r-dimred)
+       ("r-dplyr" ,r-dplyr)
+       ("r-gower" ,r-gower)
+       ("r-ipred" ,r-ipred)
+       ("r-lubridate" ,r-lubridate)
+       ("r-magrittr" ,r-magrittr)
+       ("r-purrr" ,r-purrr)
+       ("r-rcpproll" ,r-rcpproll)
+       ("r-rlang" ,r-rlang)
+       ("r-tibble" ,r-tibble)
+       ("r-tidyselect" ,r-tidyselect)
+       ("r-timedate" ,r-timedate)))
+    (home-page "https://github.com/topepo/recipes")
+    (synopsis "Preprocessing tools to create design matrices")
+    (description
+     "Recipes is an extensible framework to create and preprocess design
+matrices.  Recipes consist of one or more data manipulation and analysis
+\"steps\".  Statistical parameters for the steps can be estimated from an
+initial data set and then applied to other data sets.  The resulting design
+matrices can then be used as inputs into statistical or machine learning
+models.")
+    (license license:gpl2)))
+
+(define-public r-pdist
+  (package
+    (name "r-pdist")
+    (version "1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "pdist" version))
+       (sha256
+        (base32
+         "18nd3mgad11f2zmwcp0w3sxlch4a9y6wp8dfdyzvjn7y4b4bq0dd"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/jeffwong/pdist")
+    (synopsis "Partitioned distance function")
+    (description
+     "Pdist computes the euclidean distance between rows of a matrix X and
+rows of another matrix Y.  Previously, this could be done by binding the two
+matrices together and calling @code{dist}, but this creates unnecessary
+computation by computing the distances between a row of X and another row of
+X, and likewise for Y.  Pdist strictly computes distances across the two
+matrices, not within the same matrix, making computations significantly faster
+for certain use cases.")
+    (license license:gpl3+)))
+
+(define-public r-ggrepel
+  (package
+    (name "r-ggrepel")
+    (version "0.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ggrepel" version))
+       (sha256
+        (base32
+         "0g0qfm6g71rv27423c1x846ipilnj213knyzrcr09vrpxc87l618"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)
+       ("r-rcpp" ,r-rcpp)
+       ("r-scales" ,r-scales)))
+    (home-page "http://github.com/slowkow/ggrepel")
+    (synopsis "Repulsive text and label geometries for ggplot2")
+    (description
+     "This package provides text and label geometries for ggplot2 that help to
+avoid overlapping text labels.  Labels repel away from each other and away
+from the data points.")
+    (license license:gpl3)))
+
+(define-public r-corrplot
+  (package
+    (name "r-corrplot")
+    (version "0.84")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "corrplot" version))
+       (sha256
+        (base32
+         "1k03qd8db7pwg1v318xapx5mpiypiz2n07qr19c4b45diri5xkhd"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/taiyun/corrplot")
+    (synopsis "Visualization of a correlation matrix")
+    (description
+     "This package provides a graphical display of a correlation matrix or
+general matrix.  It also contains some algorithms to do matrix reordering.  In
+addition, corrplot is good at details, including choosing color, text labels,
+color labels, layout, etc.")
+    ;; Any version of the GPL
+    (license license:gpl2+)))
+
+(define-public r-stringdist
+  (package
+    (name "r-stringdist")
+    (version "0.9.4.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "stringdist" version))
+       (sha256
+        (base32
+         "0j5b7hr53nr9xq44famkpwzi4khix93ffani5pwldqkf8bpdvhci"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/markvanderloo/stringdist")
+    (synopsis "Approximate string matching and string distance functions")
+    (description
+     "This package implements an approximate string matching version of R's
+native @code{match} function.  It can calculate various string distances based
+on edits (Damerau-Levenshtein, Hamming, Levenshtein, optimal sting alignment),
+qgrams (q- gram, cosine, jaccard distance) or heuristic metrics (Jaro,
+Jaro-Winkler).  An implementation of soundex is provided as well.  Distances
+can be computed between character vectors while taking proper care of encoding
+or between integer vectors representing generic sequences.")
+    (license license:gpl3+)))
+
+(define-public r-mice
+  (package
+    (name "r-mice")
+    (version "2.46.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "mice" version))
+       (sha256
+        (base32
+         "1gjvlk67zvgipfczsca8zqk97vg3sivv82hblsdwp14s7smhjcax"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-lattice" ,r-lattice)
+       ("r-mass" ,r-mass)
+       ("r-nnet" ,r-nnet)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rpart" ,r-rpart)
+       ("r-survival" ,r-survival)))
+    (home-page "https://cran.r-project.org/web/packages/mice/")
+    (synopsis "Multivariate imputation by chained equations")
+    (description
+     "Multiple imputation using @dfn{Fully Conditional Specification} (FCS)
+implemented by the MICE algorithm as described in @url{Van Buuren and
+Groothuis-Oudshoorn (2011), http://doi.org/10.18637/jss.v045.i03}.  Each
+variable has its own imputation model.  Built-in imputation models are
+provided for continuous data (predictive mean matching, normal), binary
+data (logistic regression), unordered categorical data (polytomous logistic
+regression) and ordered categorical data (proportional odds).  MICE can also
+impute continuous two-level data (normal model, pan, second-level variables).
+Passive imputation can be used to maintain consistency between variables.
+Various diagnostic plots are available to inspect the quality of the
+imputations.")
+    ;; Any of these two versions.
+    (license (list license:gpl2 license:gpl3))))
+
+(define-public r-hardyweinberg
+  (package
+    (name "r-hardyweinberg")
+    (version "1.5.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "HardyWeinberg" version))
+       (sha256
+        (base32
+         "0xbcchmzii0jv0ygr91n72r39j1axraxd2i607b56v4yd5d8sy4k"))))
+    (properties `((upstream-name . "HardyWeinberg")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-mice" ,r-mice)
+       ("r-rcpp" ,r-rcpp)))
+    (home-page "https://cran.r-project.org/package=HardyWeinberg")
+    (synopsis "Statistical tests and graphics for Hardy-Weinberg equilibrium")
+    (description
+     "This package contains tools for exploring Hardy-Weinberg equilibrium for
+diallelic genetic marker data.  All classical tests (chi-square, exact,
+likelihood-ratio and permutation tests) for Hardy-Weinberg equilibrium are
+included in the package, as well as functions for power computation and for
+the simulation of marker data under equilibrium and disequilibrium.  Routines
+for dealing with markers on the X-chromosome are included.  Functions for
+testing equilibrium in the presence of missing data by using multiple
+imputation are also provided.  Implements several graphics for exploring the
+equilibrium status of a large set of diallelic markers: ternary plots with
+acceptance regions, log-ratio plots and Q-Q plots.")
+    (license license:gpl2+)))
+
+(define-public r-sm
+  (package
+    (name "r-sm")
+    (version "2.2-5.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "sm" version))
+       (sha256
+        (base32
+         "0hnq5s2fv94gaj0nyqc1vjdjd64vsp9z23nqa8hxvjcaf996rwj9"))))
+    (build-system r-build-system)
+    (native-inputs `(("gfortran" ,gfortran)))
+    (home-page "http://www.stats.gla.ac.uk/~adrian/sm/")
+    (synopsis "Smoothing methods for nonparametric regression and density estimation")
+    (description
+     "This is software accompanying the book 'Applied Smoothing Techniques for
+Data Analysis---The Kernel Approach with S-Plus Illustrations', Oxford
+University Press.  It provides smoothing methods for nonparametric regression
+and density estimation")
+    (license license:gpl2+)))
+
+(define-public r-vioplot
+  (package
+    (name "r-vioplot")
+    (version "0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "vioplot" version))
+       (sha256
+        (base32
+         "16wkb26kv6qr34hv5zgqmgq6zzgysg9i78pvy2c097lr60v087v0"))))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-sm" ,r-sm)))
+    (home-page "http://wsopuppenkiste.wiso.uni-goettingen.de/~dadler")
+    (synopsis "Violin plot")
+    (description
+     "This package provides a violin plot, which is a combination of a box
+plot and a kernel density plot.")
+    (license license:bsd-3)))
+
+(define-public r-rsofia
+  (package
+    (name "r-rsofia")
+    (version "1.1")
+    (source (origin
+              (method url-fetch)
+              ;; This package has been removed from CRAN, so we can
+              ;; only fetch it from the archives.
+              (uri (string-append "https://cran.r-project.org/src/"
+                                  "contrib/Archive/RSofia/RSofia_"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0q931y9rcf6slb0s2lsxhgqrzy4yqwh8hb1124nxg0bjbxvjbihn"))))
+    (properties `((upstream-name . "RSofia")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-rcpp" ,r-rcpp)))
+    (home-page "https://cran.r-project.org/src/contrib/Archive/RSofia")
+    (synopsis "Port of sofia-ml to R")
+    (description "This package is a port of sofia-ml to R.  Sofia-ml is a
+suite of fast incremental algorithms for machine learning that can be used for
+training models for classification or ranking.")
+    (license license:asl2.0)))
+
+(define-public r-bbmle
+  (package
+    (name "r-bbmle")
+    (version "1.0.20")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "bbmle" version))
+       (sha256
+        (base32
+         "1xzij7swrrzl5ly8l3lw6awh486zcm00251dwqws1y23fbgyh3vc"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-lattice" ,r-lattice)
+       ("r-mass" ,r-mass)
+       ("r-numderiv" ,r-numderiv)))
+    (home-page "http://cran.r-project.org/web/packages/bbmle/")
+    (synopsis "Tools for General Maximum Likelihood Estimation")
+    (description
+     "This package provides methods and functions for fitting maximum
+likelihood models in R.  This package modifies and extends the @code{mle}
+classes in the @code{stats4} package.")
+    ;; Any version of the GPL
+    (license license:gpl2+)))
+
+(define-public r-xts
+  (package
+    (name "r-xts")
+    (version "0.10-0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "xts" version))
+       (sha256
+        (base32
+         "1w7lxy3hbf005fvpzbwiznj8jbxi07s4189vbgxisd35l9a4v6q4"))))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-zoo" ,r-zoo)))
+    (native-inputs `(("gfortran" ,gfortran)))
+    (home-page "https://github.com/joshuaulrich/xts")
+    (synopsis "Extensible time series")
+    (description
+     "This package provides for uniform handling of R's different time-based
+data classes by extending @code{zoo}, maximizing native format information
+preservation and allowing for user-level customization and extension, while
+simplifying cross-class interoperability.")
+    (license license:gpl2+)))
+
+(define-public r-performanceanalytics
+  (package
+    (name "r-performanceanalytics")
+    (version "1.4.3541")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "PerformanceAnalytics" version))
+       (sha256
+        (base32
+         "1czchsccsbdfjw743j6rm101q2q01pggyl8zmlva213pwm86zb3v"))))
+    (properties
+     `((upstream-name . "PerformanceAnalytics")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-xts" ,r-xts)
+       ("r-zoo" ,r-zoo)))
+    (native-inputs `(("gfortran" ,gfortran)))
+    (home-page "http://r-forge.r-project.org/projects/returnanalytics/")
+    (synopsis "Econometric tools for performance and risk analysis")
+    (description "This is a collection of econometric functions for
+performance and risk analysis.  This package aims to aid practitioners and
+researchers in utilizing the latest research in analysis of non-normal return
+streams.  In general, it is most tested on return (rather than price) data on
+a regular scale, but most functions will work with irregular return data as
+well, and increasing numbers of functions will work with P&L or price data
+where possible.")
+    ;; Either version may be picked.
+    (license (list license:gpl2 license:gpl3))))
+
+(define-public r-laeken
+  (package
+    (name "r-laeken")
+    (version "0.4.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "laeken" version))
+       (sha256
+        (base32
+         "1rhkv1kk508pwln1d325iq4fink2ncssps0ypxi52j9d7wk78la6"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-boot" ,r-boot)
+       ("r-mass" ,r-mass)))
+    (home-page "http://cran.r-project.org/web/packages/laeken/")
+    (synopsis "Estimation of indicators on social exclusion and poverty")
+    (description "This package provides tools for the estimation of indicators
+on social exclusion and poverty, as well as an implementation of Pareto tail
+modeling for empirical income distributions.")
+    (license license:gpl2+)))
+
+(define-public r-vcd
+  (package
+    (name "r-vcd")
+    (version "1.4-3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "vcd" version))
+       (sha256
+        (base32
+         "05azric2w8mrsdk7y0484cjygcgcmbp96q2v500wvn91fj98kkhp"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-colorspace" ,r-colorspace)
+       ("r-lmtest" ,r-lmtest)
+       ("r-mass" ,r-mass)))
+    (home-page "http://cran.r-project.org/web/packages/vcd/")
+    (synopsis "Visualizing categorical data")
+    (description "This package provides visualization techniques, data sets,
+summary and inference procedures aimed particularly at categorical data.
+Special emphasis is given to highly extensible grid graphics.  The package was
+originally inspired by the book \"Visualizing Categorical Data\" by Michael
+Friendly and is now the main support package for a new book, \"Discrete Data
+Analysis with R\" by Michael Friendly and David Meyer (2015).")
+    (license license:gpl2)))