gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / cross-base.scm
index 5edc1b5..28224a1 100644 (file)
@@ -30,7 +30,6 @@
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-26)
   #:use-module (ice-9 match)
-  #:use-module (ice-9 regex)
   #:export (cross-binutils
             cross-libc
             cross-gcc))
                         `(cons "--with-sysroot=/" ,flags)))))))
     (cross binutils target)))
 
-(define (gcc-configure-flags-for-triplet target)
-  "Return a list of additional GCC `configure' flags for TARGET, a GNU triplet.
-
-The purpose of this procedure is to translate extended GNU triplets---e.g.,
-where the OS part is overloaded to denote a specific ABI---into GCC
-`configure' options.  We take extended GNU triplets that glibc recognizes."
-  (cond ((string-match "^mips64el.*gnuabin?64$" target)
-         ;; Triplets recognized by glibc as denoting the N64 ABI; see
-         ;; ports/sysdeps/mips/preconfigure.
-         '("--with-abi=64"))
-        (else
-         ;; TODO: Add `armel.*gnueabi', `hf', etc.
-         '())))
-
 (define* (cross-gcc target
                     #:optional (xbinutils (cross-binutils target)) libc)
   "Return a cross-compiler for TARGET, where TARGET is a GNU triplet.  Use
@@ -265,6 +250,7 @@ XBINUTILS and the cross tool chain."
                       (string-append linux "/include"))
               #t))
           ,phases))))
+
     (propagated-inputs `(("cross-linux-headers" ,xlinux-headers)))
     (native-inputs `(("cross-gcc" ,xgcc)
                      ("cross-binutils" ,xbinutils)