gnu: webkitgtk: Update to 2.28.2.
[jackhill/guix/guix.git] / gnu / packages / openstack.scm
index 2906a57..8dd8c19 100644 (file)
@@ -2,7 +2,7 @@
 ;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017, 2019 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages sphinx)
   #:use-module (gnu packages ssh)
   #:use-module (gnu packages time)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages version-control)
+  #:use-module (gnu packages xml)
   #:use-module (guix build-system python)
   #:use-module (guix download)
   #:use-module ((guix licenses)
@@ -85,9 +87,6 @@ appropriate plugins against the AST nodes.  Once Bandit has finished scanning
 all the files it generates a report.")
     (license asl2.0)))
 
-(define-public python2-bandit
-  (package-with-python2 python-bandit))
-
 (define-public python-debtcollector
   (package
     (name "python-debtcollector")
@@ -374,9 +373,6 @@ extensions.")
 common features used in Tempest.")
     (license asl2.0)))
 
-(define-public python2-tempest-lib
-  (package-with-python2 python-tempest-lib))
-
 ;; Packages from the Oslo library
 (define-public python-oslo.config
   (package
@@ -417,9 +413,6 @@ common features used in Tempest.")
 .ini style configuration files.")
     (license asl2.0)))
 
-(define-public python2-oslo.config
-  (package-with-python2 python-oslo.config))
-
 (define-public python-oslo.context
   (package
     (name "python-oslo.context")
@@ -521,9 +514,6 @@ configuration for all OpenStack projects.  It also provides custom formatters,
 handlers and support for context specific logging (like resource id’s etc).")
   (license asl2.0)))
 
-(define-public python2-oslo.log
-  (package-with-python2 python-oslo.log))
-
 (define-public python-oslo.serialization
   (package
     (name "python-oslo.serialization")
@@ -553,18 +543,8 @@ handlers and support for context specific logging (like resource id’s etc).")
     (description
       "The oslo.serialization library provides support for representing objects
 in transmittable and storable formats, such as JSON and MessagePack.")
-    (properties `((python2-variant . ,(delay python2-oslo.serialization))))
     (license asl2.0)))
 
-(define-public python2-oslo.serialization
-  (let ((base (package-with-python2 (strip-python2-variant
-                                     python-oslo.serialization))))
-    (package
-      (inherit base)
-      (native-inputs
-       `(("python2-ipaddress" ,python2-ipaddress)
-         ,@(package-native-inputs base))))))
-
 (define-public python-reno
   (package
     (name "python-reno")
@@ -597,7 +577,7 @@ in transmittable and storable formats, such as JSON and MessagePack.")
         ("python-sphinx" ,python-sphinx)
         ("gnupg" ,gnupg)
         ("git" ,git-minimal)))
-    (home-page "http://docs.openstack.org/developer/reno/")
+    (home-page "https://docs.openstack.org/reno/latest/")
     (synopsis "Release notes manager")
     (description "Reno is a tool for storing release notes in a git repository
 and building documentation from them.")
@@ -720,9 +700,6 @@ functions, such as encoding, exception handling, string manipulation, and time
 handling.")
     (license asl2.0)))
 
-(define-public python2-oslo.utils
-  (package-with-python2 python-oslo.utils))
-
 (define-public python-keystoneclient
   (package
     (name "python-keystoneclient")
@@ -784,21 +761,6 @@ SQLite for its identity store database, with the option to connect to external
 LDAP.")
     (license asl2.0)))
 
-(define-public python2-keystoneclient
-  (let ((keystoneclient (package-with-python2 python-keystoneclient)))
-    (package (inherit keystoneclient)
-      (propagated-inputs
-       `(("python2-requests" ,python2-requests)
-         ,@(alist-delete "python-requests"
-                         (package-propagated-inputs keystoneclient))))
-      (native-inputs
-       `(("python2-oauthlib" ,python2-oauthlib)
-         ("python2-oslosphinx" ,python2-oslosphinx)
-         ("python2-requests-mock" ,python2-requests-mock)
-         ("python2-tempest-lib" ,python2-tempest-lib)
-         ,@(fold alist-delete (package-native-inputs keystoneclient)
-            '("python-oauthlib" "python-oslosphinx" "python-requests-mock" "python-tempest-lib")))))))
-
 (define-public python-swiftclient
   (package
     (name "python-swiftclient")
@@ -838,31 +800,21 @@ data that best fit this type of storage model are virtual machine images, photo
 storage, email storage and backup archiving.  Having no central \"brain\" or
 master point of control provides greater scalability, redundancy and
 permanence.")
-    (properties `((python2-variant . ,(delay python2-swiftclient))))
     (license asl2.0)))
 
-(define-public python2-swiftclient
-  (let ((swiftclient (package-with-python2
-                      (strip-python2-variant python-swiftclient))))
-    (package (inherit swiftclient)
-      (propagated-inputs
-       `(("python2-futures" ,python2-futures)
-         ,@(package-propagated-inputs swiftclient))))))
-
 (define-public python-git-review
   (package
     (name "python-git-review")
-    (version "1.27.0")
+    (version "1.28.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "git-review" version))
        (sha256
-        (base32
-         "0xkllc8ql401sfqbjqf7i451mkgwgv0j4gysxdlyzqb27kfsyc3s"))))
+        (base32 "0nn17mfqvsa3ryjz53qjslmf60clc0vx2115kkj66h28p6vsnflf"))))
     (build-system python-build-system)
     (arguments
-     '(#:tests? #f ; tests require a running Gerrit server
+     '(#:tests? #f                     ; tests require a running Gerrit server
        #:phases
        (modify-phases %standard-phases
          (add-after 'install 'wrap-program