tests: Adjust for removal of 'device' field in <bootloader-configuration>.
[jackhill/guix/guix.git] / gnu / packages / rdesktop.scm
index 1a2d041..3c8444b 100644 (file)
@@ -1,6 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -27,6 +29,8 @@
   #:use-module (gnu packages compression)
   #:use-module (gnu packages cups)
   #:use-module (gnu packages docbook)
+  #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages glib)
   #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages image)
   #:use-module (gnu packages linux)
@@ -34,6 +38,7 @@
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages video)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages xml))
 
@@ -72,64 +77,67 @@ to remotely control a user's Windows desktop.")
     (license license:gpl3+)))
 
 (define-public freerdp
-  (let ((commit "03ab68318966c3a22935a02838daaea7b7fbe96c"))
-    (package
-      (name "freerdp")
-      (version (git-version "1.1" "1" commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      ;; We need the 1.1 branch for RDP support in vinagre.
-                      (url "git://github.com/FreeRDP/FreeRDP.git")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32 "07ish8rmvbk2zd99k91qybmmh5h4afly75l5kbvslhq1r6k8pbmp"))))
-      (build-system cmake-build-system)
-      (native-inputs
-       `(("pkg-config" ,pkg-config)
-         ("libxslt" ,libxslt)
-         ("libxml2" ,libxml2)
-         ("docbook-xsl" ,docbook-xsl)
-         ("xmlto" ,xmlto)))
-      (inputs
-       `(("libx11" ,libx11)
-         ("libxkbfile" ,libxkbfile)
-         ("libxcursor" ,libxcursor)
-         ("libxext" ,libxext)
-         ("libxi" ,libxi)
-         ("libxv" ,libxv)
-         ("libxrandr" ,libxrandr)
-         ("libxrender" ,libxrender)
-         ("libxinerama" ,libxinerama)
-         ("libxshmfence" ,libxshmfence)
-         ("cups" ,cups)
-         ("ffmpeg" ,ffmpeg-2.8)
-         ("libjpeg" ,libjpeg)
-         ("pulseaudio" ,pulseaudio)
-         ("alsa-lib" ,alsa-lib)
-         ("zlib" ,zlib)
-         ("openssl" ,openssl)))
-      (arguments
-       `(#:configure-flags
-         (list "-DCMAKE_BUILD_TYPE=RELEASE"
-               "-DWITH_JPEG=ON"
-               ,@(if (string-prefix? "x86_64"
-                                     (or (%current-target-system)
-                                         (%current-system)))
-                     '("-DWITH_SSE2=ON")
-                     '())
-               (string-append "-DDOCBOOKXSL_DIR="
-                              (assoc-ref %build-inputs "docbook-xsl")
-                              "/xml/xsl/docbook-xsl-"
-                              ,(package-version docbook-xsl))
-               "-DWITH_PULSE=ON"
-               "-DWITH_CUPS=ON")
-         #:tests? #f))                              ; no 'test' target
-      (home-page "https://www.freerdp.com")
-      (synopsis "Remote Desktop Protocol implementation")
-      (description "FreeRDP implements Microsoft's Remote Desktop Protocol.
+  (package
+    (name "freerdp")
+    (version "2.0.0-rc4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "git://github.com/FreeRDP/FreeRDP.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "0546i0m2d4nz5jh84ngwzpcm3c43fp987jk6cynqspsmvapab6da"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("docbook-xml" ,docbook-xml)
+       ("docbook-xsl" ,docbook-xsl)
+       ("glib" ,glib)
+       ("libxml2" ,libxml2)
+       ("libxslt" ,libxslt)
+       ("pkg-config" ,pkg-config)
+       ("xmlto" ,xmlto)))
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("cups" ,cups)
+       ("ffmpeg" ,ffmpeg)
+       ("libjpeg" ,libjpeg)
+       ("libx11" ,libx11)
+       ("libxkbcommon" ,libxkbcommon)
+       ("libxkbfile" ,libxkbfile)
+       ("libxcursor" ,libxcursor)
+       ("libxext" ,libxext)
+       ("libxi" ,libxi)
+       ("libxv" ,libxv)
+       ("libxrandr" ,libxrandr)
+       ("libxrender" ,libxrender)
+       ("libxinerama" ,libxinerama)
+       ("libxshmfence" ,libxshmfence)
+       ("openssl" ,openssl)
+       ("pulseaudio" ,pulseaudio)
+       ("wayland" ,wayland)
+       ("zlib" ,zlib)))
+    (arguments
+     `(#:build-type "RELEASE"
+       #:configure-flags
+       (list "-DWITH_JPEG=ON"
+             "-DWITH_LIBSYSTEMD=OFF"
+             ,@(if (string-prefix? "x86_64"
+                                   (or (%current-target-system)
+                                       (%current-system)))
+                   '("-DWITH_SSE2=ON")
+                   '())
+             (string-append "-DDOCBOOKXSL_DIR="
+                            (assoc-ref %build-inputs "docbook-xsl")
+                            "/xml/xsl/docbook-xsl-"
+                            ,(package-version docbook-xsl))
+             "-DWITH_PULSE=ON"
+             "-DWITH_CUPS=ON"
+             "-DBUILD_TESTING=ON")))
+    (home-page "https://www.freerdp.com")
+    (synopsis "Remote Desktop Protocol implementation")
+    (description "FreeRDP implements Microsoft's Remote Desktop Protocol.
 It consists of the @code{xfreerdp} client, libraries for client and server
 functionality, and Windows Portable Runtime (WinPR), a portable implementation
 of parts of the Windows API.")
-    (license license:asl2.0))))
+    (license license:asl2.0)))