gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / abduco.scm
index ae67f81..19671d1 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -18,6 +19,7 @@
 
 (define-module (gnu packages abduco)
   #:use-module (guix build-system gnu)
+  #:use-module (guix utils)
   #:use-module (guix download)
   #:use-module (guix licenses)
   #:use-module (guix packages))
 (define-public abduco
   (package
    (name "abduco")
-   (version "0.5")
+   (version "0.6")
    (source (origin
             (method url-fetch)
             (uri (string-append
-                  "http://www.brain-dump.org/projects/abduco/abduco-"
+                  "https://www.brain-dump.org/projects/abduco/abduco-"
                   version ".tar.gz"))
             (sha256
              (base32
-              "11phry5wnvwm9ckij5gxbrjfgdz3x38vpnm505q5ldc88im248mz"))))
+              "1x1m58ckwsprljgmdy93mvgjyg9x3cqrzdf3mysp0mx97zhhj2f9"))))
    (build-system gnu-build-system)
    (arguments
-    `(#:make-flags (list "CC=gcc"
+    `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
                          (string-append "PREFIX=" (assoc-ref %outputs "out")))
       #:phases (modify-phases %standard-phases
                  (delete 'configure)
@@ -45,5 +47,5 @@
    (description "abduco provides session management i.e. it allows programs to
 be run independently from their controlling terminal.  That is, programs can
 be detached---run in the background---and then later reattached.")
-   (home-page "http://www.brain-dump.org/projects/abduco/")
+   (home-page "https://www.brain-dump.org/projects/abduco/")
    (license isc)))