gnu: Add emacs-slime.
[jackhill/guix/guix.git] / gnu / packages / wget.scm
index 1f2f53c..d8a7bea 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 
 (define-module (gnu packages wget)
   #:use-module (guix licenses)
-  #:use-module ((gnu packages gettext)
-                #:renamer (symbol-prefix-proc 'guix:))
-  #:use-module (gnu packages gnutls)
+  #:use-module (gnu packages libidn)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages web)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages tls)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu))
@@ -29,7 +32,7 @@
 (define-public wget
   (package
     (name "wget")
-    (version "1.14")
+    (version "1.17.1")
     (source
      (origin
       (method url-fetch)
                           version ".tar.xz"))
       (sha256
        (base32
-        "0yqllj3nv9p3vqbdm6j4nvpjcwf1y19rq8sd966nrbd2qvvxfq8p"))))
+        "1jcpvl5sxb2ag8yahpy370c5jlfb097a21k2mhsidh4wxdhrnmgy"))))
     (build-system gnu-build-system)
     (inputs
      `(("gnutls" ,gnutls)
+       ("libidn" ,libidn)
+       ("libpsl" ,libpsl)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
        ("perl" ,perl)
-       ("gettext" ,guix:gettext)))
+       ("python" ,python)               ;for testenv suite
+       ("perl-http-daemon" ,perl-http-daemon)
+       ("perl-io-socket-ssl" ,perl-io-socket-ssl)))
     (home-page "http://www.gnu.org/software/wget/")
-    (synopsis
-     "GNU Wget, a tool for retrieving files using HTTP, HTTPS, and FTP")
+    (synopsis "Non-interactive command-line utility for downloading files")
     (description
-     "GNU Wget is a free software package for retrieving files using HTTP,
-HTTPS and FTP, the most widely-used Internet protocols.  It is a
-non-interactive commandline tool, so it may easily be called from
-scripts, cron jobs, terminals without X-Windows support, etc.")
+     "GNU Wget is a non-interactive tool for fetching files using the HTTP,
+HTTPS and FTP protocols.  It can resume interrupted downloads, use file name
+wild cards, supports proxies and cookies, and it can convert absolute links
+in downloaded documents to relative links.")
     (license gpl3+))) ; some files are under GPLv2+