gnu: ruby-listen: Update to 3.1.5.
[jackhill/guix/guix.git] / gnu / packages / dico.scm
index 317eeee..5d163a8 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -24,6 +25,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages m4)
+  #:use-module (gnu packages groff)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages python)
   #:use-module (gnu packages pcre)
 (define-public dico
   (package
     (name "dico")
-    (version "2.2")
+    (version "2.4")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/dico/dico-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "04pjks075x20d19l623mj50bw64g8i41s63z4kzzqcbg9qg96x64"))
-             (patches (map search-patch
-                           '("cpio-gets-undeclared.patch"
-                             "dico-libtool-deterministic.patch")))))
+               "13m7vahfbdj7hb38bjgd4cmfswavvxrcpppj9n4m4rar3wyzg52g"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
     (inputs
      `(("m4" ,m4)                                 ;used at run time
        ("pcre" ,pcre)
-       ;; ("python" ,python-2)
+       ("python" ,python-2)
        ("guile" ,guile-2.0)
        ("gsasl" ,gsasl)
-       ("readline" ,readline-6.2)
+       ("groff" ,groff)
+       ("readline" ,readline)
        ("zlib" ,zlib)
        ;; ("wordnet" ,wordnet) ;FIXME: link failure
        ("libltdl" ,libltdl)))
-    (home-page "http://www.gnu.org/software/dico/")
+    (home-page "https://www.gnu.org/software/dico/")
     (synopsis "Implementation of DICT server (RFC 2229)")
     (description
      "GNU Dico implements a flexible dictionary server and client according to