gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / serialization.scm
index 0b3eb7e..4ef74c2 100644 (file)
@@ -2,12 +2,12 @@
 ;;; Copyright © 2015, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
 ;;; Copyright © 2016 David Craven <david@craven.ch>
-;;; Copyright © 2016, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2016, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Corentin Bocquillon <corentin@nybble.fr>
 ;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
 ;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
-;;; Copyright © 2017 ng0 <ng0@n0.is>
+;;; Copyright © 2017 Nikita <nikita@n0.is>
 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
 ;;;
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages perl))
 
+(define-public avro-cpp-1.9
+  (package
+    (name "avro-cpp")
+    (version "1.9.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://archive.apache.org/dist/avro/avro-" version
+                    "/avro-src-" version ".tar.gz"))
+              (sha256
+               (base32 "0i3fpm7r72yw397qc8yw9ybzk2mxjkv0yk5hnn00ylc1wbd0np73"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda _ (chdir "lang/c++"))))))
+    (inputs
+     `(("boost" ,boost)
+       ("snappy" ,snappy)))
+    (home-page "https://avro.apache.org/")
+    (synopsis "Data serialization system")
+    (description "Apache Avro is a data serialization system.  Avro provides:
+@enumerate
+@item Rich data structures;
+@item a compact, fast, binary data format;
+@item a container file, to store persistent data;
+@item remote procedure call (RPC); and
+@item simple integration with dynamic languages.
+@end enumerate
+
+Code generation is not required to read or write data files nor to use or
+implement RPC protocols.")
+    (license license:asl2.0)))
+
 (define-public cereal
   (package
     (name "cereal")
@@ -60,7 +95,7 @@
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/USCiLab/cereal.git")
+             (url "https://github.com/USCiLab/cereal")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
             #t)))))
     (native-inputs
      `(("doxygen" ,doxygen)))
-    (home-page "http://uscilab.github.io/cereal/")
+    (home-page "https://uscilab.github.io/cereal/")
     (synopsis "C++11 library for serialization")
     (description
      "Cereal is a header-only C++11 serialization library.  Cereal takes
@@ -145,7 +180,7 @@ serialization.")
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/tarruda/libmpack.git")
+             (url "https://github.com/tarruda/libmpack")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
@@ -175,7 +210,7 @@ that implements both the msgpack and msgpack-rpc specifications.")
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/libmpack/libmpack-lua.git")
+             (url "https://github.com/libmpack/libmpack-lua")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
@@ -220,7 +255,7 @@ that implements both the msgpack and msgpack-rpc specifications.")
     (synopsis "Lua bindings for the libmpack binary serialization library")))
 
 (define-public lua5.1-libmpack
-  (package (inherit lua-libmpack)
+  (package/inherit lua-libmpack
     (name "lua5.1-libmpack")
     (arguments
      (substitute-keyword-arguments (package-arguments lua-libmpack)
@@ -240,7 +275,7 @@ that implements both the msgpack and msgpack-rpc specifications.")
      `(("lua" ,lua-5.1)))))
 
 (define-public lua5.2-libmpack
-  (package (inherit lua-libmpack)
+  (package/inherit lua-libmpack
     (name "lua5.2-libmpack")
     (arguments
      (substitute-keyword-arguments (package-arguments lua-libmpack)
@@ -267,7 +302,7 @@ that implements both the msgpack and msgpack-rpc specifications.")
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/jbeder/yaml-cpp.git")
+             (url "https://github.com/jbeder/yaml-cpp")
              (commit (string-append "yaml-cpp-" version))))
        (file-name (git-file-name name version))
        (sha256
@@ -297,7 +332,10 @@ that implements both the msgpack and msgpack-rpc specifications.")
                 "037d1b1qdmn3rksmn1j71j26bv4hkjv7sn7da261k853xb5899sg"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags '("-DBUILD_SHARED_LIBS:BOOL=YES")
+     `(#:configure-flags '("-DBUILD_SHARED_LIBS:BOOL=YES"
+                           ,@(if (%current-target-system)
+                                 `("-DJSONCPP_WITH_POST_BUILD_UNITTEST=OFF")
+                                 '()))
        ,@(if (%current-target-system)
              '()
              `(#:cmake ,cmake-bootstrap))))
@@ -318,7 +356,7 @@ it a convenient format to store user input files.")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/open-source-parsers/jsoncpp.git")
+                    (url "https://github.com/open-source-parsers/jsoncpp")
                     (commit version)))
               (file-name (git-file-name name version))
               (sha256
@@ -328,7 +366,7 @@ it a convenient format to store user input files.")
 (define-public capnproto
   (package
     (name "capnproto")
-    (version "0.7.0")
+    (version "0.8.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -336,7 +374,7 @@ it a convenient format to store user input files.")
                     version ".tar.gz"))
               (sha256
                (base32
-                "0hfdnhlbskagzgvby8wy6lrxj53zfzpfqimbhga68c0ji2yw1969"))))
+                "03f1862ljdshg7d0rg3j7jzgm3ip55kzd2y91q7p0racax3hxx6i"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
@@ -464,14 +502,14 @@ game development and other performance-critical applications.")
 (define-public python-feather-format
   (package
     (name "python-feather-format")
-    (version "0.4.0")
+    (version "0.4.1")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "feather-format" version))
         (sha256
          (base32
-          "1adivm5w5ji4qv7hq7942vqlk8l2wgw87bdlsia771z14z3zp857"))))
+          "00w9hwz7sj3fkdjc378r066vdy6lpxmn6vfac3qx956k8lvpxxj5"))))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-pandas" ,python-pandas)