gnu: Add lierolibre.
[jackhill/guix/guix.git] / gnu / packages / abiword.scm
index a76b16c..30c2411 100644 (file)
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,7 +23,9 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system glib-or-gtk)
   #:use-module (gnu packages)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages enchant)
@@ -41,7 +45,7 @@
 (define-public abiword
   (package
     (name "abiword")
-    (version "2.8.6")
+    (version "3.0.2")
     (source
       (origin
         (method url-fetch)
           (string-append "http://abisource.org/downloads/" name "/" version
                          "/source/" name "-" version ".tar.gz"))
         (sha256
-          (base32 "059sd2apxdmcacc4pll880i7vm18h0kyjsq299m1mz3c7ak8k46r"))
+         (base32 "08imry821g81apdwym3gcs4nss0l9j5blqk31j5rv602zmcd9gxg"))
         (patches
-          (list
-            (search-patch "abiword-wmf-version-lookup-fix.patch")
-            (search-patch "abiword-no-include-glib-internal-headers.patch")
-            (search-patch "abiword-explictly-cast-bools.patch")
-            (search-patch "abiword-use-proper-png-api.patch")
-            (search-patch "abiword-pass-no-undefined-to-linker.patch")
-            (search-patch "abiword-link-plugins-against-backend.patch")))))
+         (search-patches "abiword-wmf-version-lookup-fix.patch"
+                         "abiword-explictly-cast-bools.patch"
+                         "abiword-black-drawing-with-gtk322.patch"))))
 
-    (build-system gnu-build-system)
+    (build-system glib-or-gtk-build-system)
     (arguments                   ;; NOTE: rsvg is disabled, since Abiword
       `(#:configure-flags        ;; supports it directly, and its BS is broken.
         (list
           "--enable-clipart"     ;; TODO: The following plugins have unresolved
           "--enable-templates"   ;; dependencies: aiksaurus, grammar, wpg, gda,
-          (string-append         ;; wordperfect, psion, mathview, goffice.
+          (string-append         ;; wordperfect, psion, mathview.
             "--enable-plugins="
               "applix " "babelfish " "bmp " "clarisworks " "collab " "command "
-              "docbook " "eml " "freetranslation " "garble " "gdict " "gimp "
-              "google " "hancom " "hrtext " "iscii " "kword " "latex "
-              "loadbindings " "mht " "mif " "mswrite " "opendocument "
+              "docbook " "eml " "epub " "freetranslation " "garble " "gdict "
+              "gimp " "goffice " "google " "hancom " "hrtext " "iscii " "kword "
+              "latex " "loadbindings " "mht " "mif " "mswrite " "opendocument "
               "openwriter " "openxml " "opml " "ots " "paint " "passepartout "
               "pdb " "pdf " "presentation " "s5 " "sdw " "t602 " "urldict "
-              "wikipedia " "wmf " "wml " "xslfo"))))
+              "wikipedia " "wmf " "wml " "xslfo"))
+        ;; tests fail with: Gtk-CRITICAL **: gtk_settings_get_for_screen:
+        ;;                  assertion 'GDK_IS_SCREEN (screen)' failed
+        ;;                  GLib-GObject-CRITICAL **: g_object_get_qdata:
+        ;;                  assertion 'G_IS_OBJECT (object)' failed
+        ;; Manually starting the X server before the test phase did not help
+        ;; the tests to pass.
+        #:tests? #f
+        #:make-flags
+        (list "CXXFLAGS=-std=c++11")))
     (inputs
       `(("boost" ,boost)
         ("enchant" ,enchant)
         ("fontconfig" ,fontconfig)
         ("fribidi" ,fribidi)
         ("glib" ,glib)
-        ("gtk+" ,gtk+-2)
+        ("goffice" ,goffice)
+        ("gtk+" ,gtk+)
+        ("libchamplain" ,libchamplain)
         ("libglade" ,libglade)
         ("libgsf" ,libgsf)
         ("libjpeg" ,libjpeg)
         ("librsvg" ,librsvg)
         ("libwmf" ,libwmf)
         ("libxml2" ,libxml2)
+        ("libxslt" ,libxslt)
         ("ots" ,ots)
         ("popt" ,popt)
         ("readline" ,readline)
+        ("telepathy" ,telepathy-glib)
         ("wv" ,wv)
         ("zlib" ,zlib)))
     (native-inputs
       `(("intltool" ,intltool)
         ("glib:bin" ,glib "bin")
+        ("libtool" ,libtool)
         ("pkg-config" ,pkg-config)))
     (home-page "http://abisource.org/")
     (synopsis "Word processing program")
-    (description
-      "AbiWord is a word processing program.  It is rapidly becoming a state
-of the art word processor, with lots of features useful for your daily work,
-personal needs, or for just some good old typing fun.")
+
+    ;; HACKERS: The comment below is here so that it shows up early in the
+    ;; .pot file.
+
+    ;; TRANSLATORS: Dear translator, We would like to inform you that package
+    ;; descriptions may occasionally include Texinfo markup.  Texinfo markup
+    ;; looks like "@code{rm -rf}", "@emph{important}", etc.  When translating,
+    ;; please leave markup as is.
+    (description "AbiWord is a word processing program.  It is rapidly
+becoming a state of the art word processor, with lots of features useful for
+your daily work, personal needs, or for just some good old typing fun.")
     (license license:gpl2+)))