tests: Adjust for removal of 'device' field in <bootloader-configuration>.
[jackhill/guix/guix.git] / gnu / packages / speech.scm
index 39a940d..065aa81 100644 (file)
@@ -1,6 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
+  #:use-module (gnu packages audio)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages pulseaudio)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages textutils))
 
 (define-public mitlm
   (package
     (name "mitlm")
-    (version "0.4.1")
-    ;; No official release tarballs, so for now we use the one from Debian
-    ;; that is maintained by one of the project developers.
-    ;;
-    ;; See: https://github.com/mitlm/mitlm/issues/54
+    (version "0.4.2")
     (source (origin
               (method url-fetch)
-              (uri (string-append "mirror://debian/pool/main/m/mitlm/mitlm_"
-                                  version ".orig.tar.gz"))
+              (uri (string-append "https://github.com/mitlm/mitlm/releases/"
+                                  "download/v" version "/"
+                                  name "-" version ".tar.xz"))
               (sha256
                (base32
-                "12m09xxx8jbir9cnzzaysvni5sfijpfj96z1x1520qqvmpc8lmn7"))))
+                "09fv4fcpmw9g1j0zml0k5kk1lgjw2spr8gn51llbkaaph6v8d62a"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("gfortran" ,gfortran)))
@@ -74,9 +75,12 @@ efficiency through the use of a compact vector representation of n-grams.")
        ("pkg-config" ,pkg-config)))
     (inputs
      `(("dotconf" ,dotconf)
+       ("espeak" ,espeak)
        ("glib" ,glib)
        ("libltdl" ,libltdl)
-       ("libsndfile" ,libsndfile)))
+       ("libsndfile" ,libsndfile)
+       ("pulseaudio" ,pulseaudio)
+       ("python" ,python)))
     (synopsis "Common interface to speech synthesizers")
     (description "The Speech Dispatcher project provides a high-level
 device independent layer for access to speech synthesis through a simple,
@@ -92,3 +96,36 @@ stable and well documented interface.")
                     ;; festival_client.{c,h} carries an expat-style license.
                     "See src/modules/festival_client.c in the distribution.")
                    license:gpl3+)))) ; doc/texinfo.tex -- with TeX exception.
+
+(define-public sonic
+  (package
+    (name "sonic")
+    (version "0.2.0")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "https://github.com/waywardgeek/sonic/archive/"
+                                 "release-" version ".tar.gz"))
+             (file-name (string-append name "-" version ".tar.gz"))
+             (sha256
+              (base32
+               "11a0q9wkgbb9ymf52v7dvybfhj8hprgr67zs1xcng143fvjpr0n7"))))
+    (build-system gnu-build-system)
+    (arguments
+      `(#:tests? #f ; No test suite.
+        #:make-flags
+         (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
+        #:phases
+        (modify-phases %standard-phases
+          (delete 'configure)))) ; No ./configure script.
+    (synopsis "Speed up or slow down speech")
+    (description "Sonic implements a simple algorithm for speeding up or slowing
+down speech.  However, it's optimized for speed ups of over 2X, unlike previous
+algorithms for changing speech rate.  Sonic is a C library designed to be easily
+integrated into streaming voice applications such as text-to-speech (TTS) back
+ends.
+
+The primary motivation behind Sonic is to enable the blind and visually impaired
+to improve their productivity with speech engines, like eSpeak.  Sonic can also
+be used by the sighted.")
+    (home-page "https://github.com/waywardgeek/sonic")
+    (license license:asl2.0)))