Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / attr.scm
index 907a568..3237376 100644 (file)
@@ -1,6 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2012, 2013, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public attr
   (package
     (name "attr")
-    (version "2.4.47")
+    (version "2.4.48")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://savannah/attr/attr-"
-                                  version ".src.tar.gz"))
+                                  version ".tar.gz"))
               (sha256
                (base32
-                "0nd8y0m6awc9ahv0ciiwf8gy54c8d3j51pw9xg7f7cn579jjyxr5"))))
+                "1rr4adzwax4bzr2c00f06zcsljv5y6p9wymz1g89ww7cb2rp5bay"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-after 'configure 'patch-makefile-SHELL
-           (lambda _
-             (patch-makefile-SHELL "include/buildmacros")))
-         (replace 'install
-           (lambda _
-             (zero? (system* "make"
-                             "install"
-                             "install-lib"
-                             "install-dev"))))
          (replace 'check
            (lambda* (#:key target #:allow-other-keys)
              ;; Use the right shell.
              (substitute* "test/run"
                (("/bin/sh")
-                (which "bash")))
+                (which "sh")))
 
              ;; When building natively, run the tests.
+             ;;
+             ;; Note that we use system* and unconditionally return #t here
+             ;; to ignore the test result, because the tests will fail when
+             ;; the build is performed on a file system without support for
+             ;; extended attributes, and we wish to allow Guix to be built
+             ;; on such systems.
              (unless target
                (system* "make" "tests" "-C" "test"))
-
-             ;; XXX: Ignore the test result since this is
-             ;; dependent on the underlying file system.
              #t)))))
     (inputs
      ;; Perl is needed to run tests; remove it from cross builds.
@@ -71,8 +67,8 @@
     (native-inputs
      `(("gettext" ,gettext-minimal)))
 
-    (home-page "http://savannah.nongnu.org/projects/attr/")
+    (home-page "https://savannah.nongnu.org/projects/attr/")
     (synopsis "Library and tools for manipulating extended attributes")
     (description
      "Portable library and tools for manipulating extended attributes.")
-    (license (list gpl2+ lgpl2.1+))))
+    (license lgpl2.1+)))