gnu: Add PadWalker.
[jackhill/guix/guix.git] / gnu / packages / texlive.scm
index 5d6cc65..f757350 100644 (file)
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,8 +37,9 @@
   #:use-module (gnu packages python)
   #:use-module (gnu packages ruby)
   #:use-module (gnu packages tcsh)
-  #:use-module (gnu packages which)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages xorg)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages zip)
   #:autoload   (gnu packages texinfo) (texinfo))
 
              ("libpng" ,libpng)
              ("libxaw" ,libxaw)
              ("libxt" ,libxt)
+             ("perl" ,perl)
              ("pixman" ,pixman)
              ("poppler" ,poppler)
              ("potrace" ,potrace)
+             ("python" ,python-2) ; incompatible with Python 3 (print syntax)
              ("ruby" ,ruby)
+             ("tcsh" ,tcsh)
              ("teckit" ,teckit)
              ("zlib" ,zlib)
              ("zziplib" ,zziplib)))
    (native-inputs
-    `(("perl" ,perl)
-      ("pkg-config" ,pkg-config)
-      ("python" ,python-2) ; incompatible with Python 3 (print syntax)
-      ("tcsh" ,tcsh)))
+    `(("pkg-config" ,pkg-config)))
    (outputs '("out" "data"))
    (arguments
     `(#:out-of-source? #t
 
       ;; Disable tests on mips64 to cope with a failure of luajiterr.test.
       ;; XXX FIXME fix luajit properly on mips64.
-      #:tests? ,(not (equal? "mips64el-linux" (or (%current-target-system)
+      #:tests? ,(not (string-prefix? "mips64" (or (%current-target-system)
                                                   (%current-system))))
       #:phases
        (alist-cons-after