gnu: Add python-ld.
[jackhill/guix/guix.git] / gnu / packages / batik.scm
index 180d7e7..9cff05d 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,7 +24,6 @@
   #:use-module (guix git-download)
   #:use-module (guix packages)
   #:use-module (guix build-system ant)
-  #:use-module (guix build utils)
   #:use-module (gnu packages)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages java)
@@ -140,8 +140,8 @@ public interface EventListenerInitializer {
     (native-inputs
      `(("unzip" ,unzip)))
     (home-page "https://www.w3.org/Style/CSS/SAC/")
-    (synopsis "W3C SVG interface")
-    (description "This package provides a SVG interface.")
+    (synopsis "W3C SVG 1.0 interface")
+    (description "This package provides a SVG 1.0 interface.")
     (license license:w3c)))
 
 (define-public java-w3c-svg
@@ -162,7 +162,9 @@ public interface EventListenerInitializer {
        `(modify-phases ,phases
           (delete 'patch-interface)))))
     (propagated-inputs
-     `())))
+     `())
+    (synopsis "W3C SVG interface")
+    (description "This package provides a SVG interface.")))
 
 (define-public java-w3c-sac
   (package
@@ -197,7 +199,7 @@ SAC is an interface for CSS parsers.")
 (define-public java-xmlgraphics-commons
   (package
     (name "java-xmlgraphics-commons")
-    (version "2.3")
+    (version "2.6")
     (source
       (origin
         (method url-fetch)
@@ -205,8 +207,7 @@ SAC is an interface for CSS parsers.")
               "mirror://apache/xmlgraphics/commons/source/xmlgraphics-commons-"
               version "-src.tar.gz"))
         (sha256
-         (base32
-          "0a432a4ca3vgnbada5cy9mlmfzmq6hi4i176drfxrp17q2d43w23"))
+         (base32 "18gndjwzdd6vhp59fn8cwn6i6q0v0ym8nmwn65rcykdrzz0nvl72"))
         (modules '((guix build utils)))
         (snippet
          `(begin