gnu: datefudge: Update to 1.23.
[jackhill/guix/guix.git] / gnu / packages / simulation.scm
index 2132d4a..edc8d6e 100644 (file)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages version-control)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
   #:use-module (guix download)
-  #:use-module (guix build utils)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
@@ -268,6 +268,11 @@ problems for efficient solution on parallel systems.")
              (setenv "PYTHONPATH"
                      (string-append (getcwd) ":" (getenv "PYTHONPATH")))
              (with-directory-excursion "test"
+               ;; Disable parallel tests to avoid race condition.  See
+               ;; https://github.com/pytest-dev/pytest-cov/issues/237.
+               (substitute* "runtests.sh"
+                 (("for p in 1 4 8 16; do")
+                  "for p in 1; do"))
                (invoke "./runtests.sh"))
              #t)))))
     (home-page "https://bitbucket.org/fenics-project/dijitso/")
@@ -459,6 +464,10 @@ FFC is part of the FEniCS Project.")
                               "${DOLFIN_SOURCE_DIR} "
                               "${DOLFIN_SOURCE_DIR}/dolfin "
                               "${DOLFIN_BINARY_DIR})\n")))
+            (substitute* "dolfin/nls/PETScSNESSolver.cpp"
+              ;; Remove SNESTEST mapping.  The SNESTEST symbol was removed
+              ;; from PETSc at version 3.10.3.
+              ((".*SNESTEST.*") "" ))
             #t))))
     (build-system cmake-build-system)
     (inputs
@@ -611,7 +620,7 @@ user interface to the FEniCS core components and external libraries.")
        ("python-matplotlib" ,python-matplotlib)
        ,@(alist-delete "python" (package-inputs fenics-dolfin))))
     (native-inputs
-     `(("cmake" ,cmake)
+     `(("cmake" ,cmake-minimal)
        ("ply" ,python-ply)
        ("pytest" ,python-pytest)
        ("python-decorator" ,python-decorator)