gnu: r-fields: Update to 11.4.
[jackhill/guix/guix.git] / gnu / packages / gxmessage.scm
index 649b9d4..0150dd0 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public gxmessage
   (package
     (name "gxmessage")
-    (version "2.20.1")
+    (version "3.4.3")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gxmessage/gxmessage-"
                                  version ".tar.gz"))
              (sha256
-              (base32 "1b75qjx339c7q0xfxnwb2n5vw6xn8vi6nw2clggfzxnwwx58g2d1"))))
+              (base32 "01ggvvp0nyn8xczh93icifnji468wsjgqzd1f1bixwsqziaicknv"))))
     (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'skip-gtk-update-icon-cache
+           ;; Don't create 'icon-theme.cache'.
+           (lambda _
+             (substitute* "Makefile"
+               (("gtk-update-icon-cache") "true"))
+             #t)))))
     (inputs
-     `(("gtk+" ,gtk+-2)))
+     `(("gtk+" ,gtk+)))
     (native-inputs
      `(("intltool" ,intltool)
        ("pkg-config" ,pkg-config)))
-    (home-page "http://www.gnu.org/software/gxmessage/")
+    (home-page "https://www.gnu.org/software/gxmessage/")
     (synopsis "Open popup message window with buttons for return")
     (description "GNU gxmessage is a program that pops up dialog windows, which display
 a message to the user and waits for their action.  The program then exits