gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / acl.scm
index 8d5f011..abeafee 100644 (file)
@@ -4,6 +4,9 @@
 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2021 Lars-Dominik Braun <ldb@leibniz-psychology.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix licenses)
   #:use-module (gnu packages attr)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages check)
+  #:use-module (gnu packages hurd)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages perl)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (gnu packages)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python))
 
 (define-public acl
   (package
     (name "acl")
-    (version "2.2.52")
+    (version "2.2.53")
     (source
      (origin
       (method url-fetch)
       (uri (string-append "mirror://savannah/acl/acl-"
-                          version ".src.tar.gz"))
+                          version ".tar.gz"))
       (sha256
        (base32
-        "08qd9s3wfhv0ajswsylnfwr5h0d7j9d4rgip855nrh400nxp940p"))
-      (patches (search-patches "acl-fix-perl-regex.patch"
-                               "acl-hurd-path-max.patch"))))
+        "1ir6my3w74s6nfbgbqgzj6w570sn0qjf3524zx8xh67lqrjrigh6"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:test-target "tests"
-       #:modules ((ice-9 ftw)
+     `(#:modules ((ice-9 ftw)
                   ,@%gnu-build-system-modules)
+       #:configure-flags '("--disable-static")
+       #:tests? ,(not (or (%current-target-system)
+                          (hurd-target?)))
        #:phases
        (modify-phases %standard-phases
          ;; XXX After repacking the sources the timestamps are reset to the
                           (("\\| sed.*'") ""))
              ;; These tests require the existence of a user named "bin", but
              ;; this user does not exist within Guix's build environment.
-             (for-each (lambda (file)
-                         (delete-file (string-append "test/" file)))
-                       '("setfacl-X.test" "cp.test" "misc.test"))
-             #t))
-         (replace 'install
-           (lambda _
-             (invoke "make" "install" "install-lib" "install-dev"))))))
+             (substitute* "Makefile.in"
+               ((".*test/misc\\.test.*") "")
+               ((".*test/cp\\.test.*") "")
+               ((".*test/setfacl-X\\.test.*") ""))
+             #t)))))
     (inputs `(("attr" ,attr)))
     (native-inputs
      `(("gettext" ,gettext-minimal)
     (description
      "Library and tools for manipulating access control lists.")
     (license (list gpl2+ lgpl2.1+))))
+
+(define-public python-pylibacl
+  (package
+    (name "python-pylibacl")
+    (version "0.6.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "pylibacl" version))
+        (sha256
+          (base32
+            "1zyrk2m20p5b6bdwxhrwib273i6i71zyr5hzssbxfqis5qra9848"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'disable-tests
+           (lambda* (#:key outputs inputs #:allow-other-keys)
+             ;; These tests operate on real files, but our tempfs does not support
+             ;; ACLs
+             (substitute* "tests/test_acls.py"
+               (("( *)def test_applyto(_extended(_mixed)?)?" match indent)
+                (string-append indent "@pytest.mark.skip(reason=\"guix\")\n" match)))
+             #t))
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "pytest" "tests"))
+               #t)))))
+    (inputs `(("acl" ,acl)))
+    (native-inputs `(("python-pytest" ,python-pytest)))
+    (home-page "https://pylibacl.k1024.org/")
+    (synopsis "POSIX.1e ACLs for python")
+    (description "Python 3.4+ extension module that allows you to manipulate
+the POSIX.1e Access Control Lists present in some OS/file-systems
+combinations.")
+    (license lgpl2.1+)))