gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / netpbm.scm
index 2d76d7e..7fe0503 100644 (file)
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -52,6 +53,8 @@
             (sha256
               (base32
                "1k7as9qi1942wyjxpvbf02wg0h4braw44m3m3vvi8sm9y5z1m967"))
+            (patches (search-patches "netpbm-CVE-2017-2586.patch"
+                                     "netpbm-CVE-2017-2587.patch"))
             (file-name (string-append name "-" version "-checkout"))
             (modules '((guix build utils)))
             (snippet
@@ -94,7 +97,8 @@
                   (("^DATE=.*")
                    "DATE=\"Thu Jan 01 00:00:00+0000 1970\"\n")
                   (("^USER=.*")
-                   "USER=Guix\n"))))))
+                   "USER=Guix\n"))
+                #t))))
 
    (build-system gnu-build-system)
    (inputs `(("ghostscript" ,ghostscript)
              ;; 'gsc', so look for that instead.
              (substitute* "converter/other/pstopnm.c"
                (("\"%s/gs\"")
-                "\"%s/gsc\"")))
+                "\"%s/gsc\"")
+               (("/usr/bin/gs")
+                (string-append (assoc-ref inputs "ghostscript") "/bin/gsc"))))
            #t))
        (add-before 'check 'setup-check
          (lambda _