gnu: webkitgtk: Update to 2.28.2.
[jackhill/guix/guix.git] / gnu / packages / wdiff.scm
index 6aa6b2a..20fc0bc 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages screen)
-  #:use-module (gnu packages which))
+  #:use-module (gnu packages base))
 
 (define-public wdiff
   (package
     (name "wdiff")
-    (version "1.2.1")
+    (version "1.2.2")
     (source
      (origin
       (method url-fetch)
                           version ".tar.gz"))
       (sha256
        (base32
-        "1gb5hpiyikada9bwz63q3g96zs383iskiir0xsqynqnvq1vd4n41"))))
+        "0sxgg0ms5lhi4aqqvz1rj4s77yi9wymfm3l3gbjfd1qchy66kzrl"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases (alist-cons-before
-                 'check 'fix-sh
-                 (lambda _
-                   (substitute* "tests/testsuite"
-                     (("#! /bin/sh")
-                      (string-append "#!" (which "sh")))))
-                 %standard-phases)))
-    (inputs `(("screen" ,screen)
-              ("which" ,which)
-
-              ;; For some reason wdiff.info gets rebuilt.
-              ("texinfo" ,texinfo)))
+     `(#:phases (modify-phases %standard-phases
+                  (add-before 'check 'fix-sh
+                    (lambda _
+                      (substitute* "tests/testsuite"
+                        (("#! /bin/sh")
+                         (string-append "#!" (which "sh")))))))))
+    (native-inputs
+     `(("which" ,which)
+       ;; For some reason wdiff.info gets rebuilt.
+       ("texinfo" ,texinfo)))
     (home-page "https://www.gnu.org/software/wdiff/")
     (synopsis "Word difference finder")
     (description
-     "GNU Wdiff is a front end to 'diff' for comparing files on a word per
-word basis.  A word is anything between whitespace.  This is useful for
-comparing two texts in which a few words have been changed and for which
-paragraphs have been refilled.  It works by creating two temporary files, one
-word per line, and then executes 'diff' on these files.  It collects the
-'diff' output and uses it to produce a nicer display of word differences
-between the original files.")
+     "GNU Wdiff is a front-end to the diff program from Diffutils that
+allows you to compare files on a word-by-word basis, where a word is anything
+between whitespace.")
     (license gpl3+)))