gnu: gnupg: Upgrade support libraries.
[jackhill/guix/guix.git] / gnu / packages / xorg.scm
index 93e2da5..cde6475 100644 (file)
@@ -177,7 +177,7 @@ tracking.")
 
 
 
-    ;; packages without propagated input
+;; packages without propagated input
 ;; (rationale for this separation: The packages in PROPAGATED_INPUTS need to
 ;; be defined first, the split makes book-keeping easier.)
 
@@ -3628,21 +3628,8 @@ tracking.")
       `(("gettext" ,gnu:gettext)
         ("intltool" ,intltool)
         ("libx11" ,libx11)
-        ;; required to set PERL5LIB, although it is propagated by intltool
-        ("perl-xml-parser" ,perl-xml-parser)
         ("pkg-config" ,pkg-config)
         ("xkbcomp" ,xkbcomp)))
-    (arguments
-      `(#:phases
-         (alist-replace
-          'configure
-          (lambda* (#:key inputs #:allow-other-keys #:rest args)
-            (let ((configure (assoc-ref %standard-phases 'configure))
-                  (perl-xml-parser (assoc-ref inputs "perl-xml-parser")))
-              ;; FIXME: This should be done more centrally.
-              (setenv "PERL5LIB" (string-append perl-xml-parser "/lib/perl5/site_perl"))
-              (apply configure args)))
-         %standard-phases)))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -4632,15 +4619,7 @@ tracking.")
           (lambda* (#:key #:allow-other-keys)
             ;; remove dangling symlink to /usr/include/wine/windows
             (delete-file "src/gallium/state_trackers/d3d1x/w32api"))
-         (alist-replace
-          'configure
-          (lambda* (#:key inputs #:allow-other-keys #:rest args)
-            (let ((configure (assoc-ref %standard-phases 'configure))
-                  (libxml2 (assoc-ref inputs "libxml2")))
-              ;; FIXME: This should be done more centrally.
-              (setenv "PYTHONPATH" (string-append libxml2 "/lib/python2.7/site-packages"))
-              (apply configure args)))
-         %standard-phases))))
+         %standard-phases)))
     (home-page "http://mesa3d.org/")
     (synopsis "Mesa, an OpenGL implementation")
     (description "Mesa is a free implementation of the OpenGL specification -
@@ -4867,3 +4846,33 @@ emulation to complete hardware acceleration for modern GPUs.")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
     (license license:x11)))
+
+
+;; package outside the x.org system proper of height 5
+
+(define-public libxaw3d
+  (package
+    (name "libxaw3d")
+    (version "1.6.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "mirror://xorg/individual/lib/libXaw3d-"
+               version
+               ".tar.bz2"))
+        (sha256
+          (base32
+            "0awplv1nf53ywv01yxphga3v6dcniwqnxgnb0cn4khb121l12kxp"))))
+    (build-system gnu-build-system)
+    (propagated-inputs
+      `(("libxext" ,libxext)
+        ("libxmu" ,libxmu)
+        ("libxt" ,libxt)))
+    (inputs
+      `(("libx11" ,libx11)
+        ("pkg-config" ,pkg-config)))
+    (home-page "http://www.x.org/wiki/")
+    (synopsis "xorg implementation of the X Window System")
+    (description "X.org provides an implementation of the X Window System")
+    (license license:x11)))