gnu: Add 'make-ld-wrapper' procedure.
[jackhill/guix/guix.git] / gnu / packages / dejagnu.scm
index 3318c81..203bd6e 100644 (file)
@@ -26,7 +26,7 @@
 (define-public dejagnu
   (package
     (name "dejagnu")
-    (version "1.5.1")
+    (version "1.5.2")
     (source
      (origin
       (method url-fetch)
@@ -34,7 +34,7 @@
                           version ".tar.gz"))
       (sha256
        (base32
-        "1lik8h4qi7x0mhsi8xmj91an1yb63rjbk6v4xrmzgiy5lk8lgrv0"))))
+        "18ikblg4x4y5fkw8sg0c2zmqgxdqqycswmws17sxx8m4sz6g7dch"))))
     (build-system gnu-build-system)
     (inputs `(("expect" ,expect)))
     (arguments
      "http://www.gnu.org/software/dejagnu/")
     (synopsis "GNU software testing framework")
     (description
-     "DejaGnu is a framework for testing other programs.  Its purpose
-is to provide a single front end for all tests.  Think of it as a
-custom library of Tcl procedures crafted to support writing a
-test harness.  A test harness is the testing infrastructure that
-is created to support a specific program or tool.  Each program
-can have multiple testsuites, all supported by a single test
-harness.  DejaGnu is written in Expect, which in turn uses Tcl --
-Tool command language.")
+     "DejaGnu is a framework for testing software.  In effect, it serves as
+a front-end for all tests written for a program.  Thus, each program can have
+multiple test suites, which are then all managed by a single harness.")
     (license gpl2+)))