gnu: itstool: Add python2-libxml2 to propagated-inputs.
[jackhill/guix/guix.git] / gnu / packages / libidn.scm
index dcb0872..49dafbe 100644 (file)
 (define-public libidn
   (package
    (name "libidn")
-   (version "1.26")
+   (version "1.30")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/libidn/libidn-" version
                                 ".tar.gz"))
             (sha256 (base32
-                     "0g657kv60rh486m7bwyp5k24ljmym4wnb8nmk6d3i3qgr1qlqbqa"))))
+                     "0lxh5r1z8gsk4jxx3rv8aasjv8p53j4y04kvfn2w30a0syagrf9r"))))
    (build-system gnu-build-system)
 ;; FIXME: No Java and C# libraries are currently built.
    (synopsis "Internationalized string processing library")
    (description
-    "GNU Libidn is a fully documented implementation of the Stringprep,
-Punycode and IDNA specifications. Libidn's purpose is to encode and decode
-internationalised domain names.
-
-The library contains a generic Stringprep implementation. Profiles for
-Nameprep, iSCSI, SASL, XMPP and Kerberos V5 are included. Punycode and
-ASCII Compatible Encoding (ACE) via IDNA are supported. A mechanism to
-define Top-Level Domain (TLD) specific validation tables, and to compare
-strings against those tables, is included.
-Default tables for some TLDs are also included.")
+     "libidn is a library implementing of the Stringprep, Punycode and IDNA
+specifications.  These are used to encode and decode internationalized domain
+names.  It includes native C, C# and Java libraries.")
    (license lgpl2.1+)
    (home-page "http://www.gnu.org/software/libidn/")))