Merge branch 'origin/core-updates-next' into core-updates
[jackhill/guix/guix.git] / gnu / packages / gnupg.scm
index a389186..8a8a1f5 100644 (file)
@@ -70,7 +70,7 @@
 (define-public libgpg-error
   (package
     (name "libgpg-error")
-    (version "1.27")
+    (version "1.29")
     (source
      (origin
       (method url-fetch)
@@ -78,7 +78,7 @@
                           version ".tar.bz2"))
       (sha256
        (base32
-        "1li95ni122fzinzlmxbln63nmgij63irxfvi52ws4zfbzv3am4sg"))))
+        "1smihcrhkfy58kazjaigmfbagy52rw98fqfsv1x7ml8razx2dsgc"))))
     (build-system gnu-build-system)
     (home-page "https://gnupg.org")
     (synopsis "Library of error values for GnuPG components")
@@ -108,14 +108,14 @@ Daemon and possibly more in the future.")
 (define-public libgcrypt
   (package
     (name "libgcrypt")
-    (version "1.8.1")
+    (version "1.8.2")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnupg/libgcrypt/libgcrypt-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "1cvqd9jk5qshbh48yh3ixw4zyr4n5k50r3475rrh20xfn7w7aa3s"))))
+               "01sca9m8hm6b5v8hmqsfdjhyz013869p1f0fxw9ln52qfnp4q1n8"))))
     (build-system gnu-build-system)
     (propagated-inputs
      `(("libgpg-error-host" ,libgpg-error)))
@@ -369,7 +369,8 @@ libskba (working with X.509 certificates and CMS data).")
          (add-after 'unpack 'patch-check-sh
            (lambda _
              (substitute* "checks/Makefile.in"
-               (("/bin/sh") (which "sh"))))))))))
+               (("/bin/sh") (which "sh")))
+             #t)))))))
 
 (define-public gpgme
   (package
@@ -623,84 +624,87 @@ PGP keysigning parties.")
    (home-page "https://www.phildev.net/pius/index.shtml")))
 
 (define-public signing-party
-  (package
-   (name "signing-party")
-   (version "2.6")
-   (source (origin
-            (method url-fetch)
-            (uri (string-append "mirror://debian/pool/main/s/signing-party/"
-                                "signing-party_" version ".orig.tar.gz"))
-            (sha256 (base32
-                     "1n5bpcfpl9vg1xp6r1jhbyahrgdyxp05b5pria1rh4m0qnv8sifr"))))
-   (build-system gnu-build-system)
-   (native-inputs
-    `(("autoconf" ,autoconf-wrapper)
-      ("automake" ,automake)))
-   (inputs `(("perl" ,perl)
-             ("perl-text-template" ,perl-text-template)
-             ("perl-mime-tools" ,perl-mime-tools)
-             ("perl-gnupg-interface" ,perl-gnupg-interface)
-             ("perl-net-idn-encode" ,perl-net-idn-encode)
-             ("libmd" ,libmd)))
-   (arguments
-    `(#:tests? #f
-      #:phases
-      (modify-phases %standard-phases
-        (add-before 'configure 'change-directory
-          (lambda _
-            ;; The build system in the unpack phase changes to a less useful
-            ;; subdirectory, so move up one level
-            (chdir (dirname (getcwd)))))
-        (replace 'configure
-          (lambda* (#:key outputs #:allow-other-keys)
-            (let ((out (assoc-ref outputs "out")))
-              (substitute* "keyanalyze/Makefile"
-                (("LDLIBS") (string-append "CC=" (which "gcc") "\nLDLIBS")))
-              (substitute* "keyanalyze/Makefile"
-                (("\\./configure") (string-append "./configure --prefix=" out)))
-              (substitute* "gpgwrap/src/Makefile"
-                (("\\} clean")
-                 (string-append "} clean\ninstall:\n\tinstall -D bin/gpgwrap "
-                                out "/bin/gpgwrap\n")))
-              (substitute* '("gpgsigs/Makefile" "keyanalyze/Makefile"
-                             "keylookup/Makefile" "sig2dot/Makefile"
-                             "springgraph/Makefile")
-                (("/usr") out))
-              (setenv "CONFIG_SHELL" (which "sh")))))
-        (replace 'install
-          (lambda* (#:key outputs #:allow-other-keys #:rest args)
-            (let ((out (assoc-ref outputs "out"))
-                  (install (assoc-ref %standard-phases 'install)))
-              (apply install args)
-              (for-each
-                (lambda (dir file)
-                  (copy-file (string-append dir "/" file)
-                             (string-append out "/bin/" file)))
-                '("caff" "caff" "caff" "gpgdir" "gpg-key2ps"
-                  "gpglist" "gpg-mailkeys" "gpgparticipants")
-                '("caff" "pgp-clean" "pgp-fixkey" "gpgdir" "gpg-key2ps"
-                  "gpglist" "gpg-mailkeys" "gpgparticipants"))
-              (for-each
-                (lambda (dir file)
-                  (copy-file (string-append dir "/" file)
-                             (string-append out "/share/man/man1/" file)))
-                '("caff" "caff" "caff" "gpgdir"
-                  "gpg-key2ps" "gpglist" "gpg-mailkeys"
-                  "gpgparticipants" "gpgsigs" "gpgwrap/doc"
-                  "keyanalyze" "keyanalyze/pgpring" "keyanalyze")
-                '("caff.1" "pgp-clean.1" "pgp-fixkey.1" "gpgdir.1"
-                  "gpg-key2ps.1" "gpglist.1" "gpg-mailkeys.1"
-                  "gpgparticipants.1" "gpgsigs.1" "gpgwrap.1"
-                  "process_keys.1" "pgpring.1" "keyanalyze.1")))))
-        (add-after 'install 'wrap-programs
-          (lambda* (#:key outputs #:allow-other-keys)
-            (let* ((out (assoc-ref outputs "out")))
-              (wrap-program
-                  (string-append out "/bin/caff")
-                `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))))))))
-   (synopsis "Collection of scripts for simplifying gnupg key signing")
-   (description
-    "Signing-party is a collection for all kinds of PGP/GnuPG related things,
+  ;; Upstream moved from alioth.debian.org to salsa.debian.org but the
+  ;; automatic svn import did not preserve tags apparently, so there's no real
+  ;; version number.
+  (let ((commit "d6f2296325605ee96ddf9f5b156e5e3f667a6df3")
+        (revision "0"))
+    (package
+      (name "signing-party")
+      (version (git-version "2.6" revision commit))
+      (home-page "https://salsa.debian.org/stappers/pgp-tools")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url home-page)
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "00f7zasbwcbjzd92br2j10pyjxv0aw1qb4540qfz2dxzxgmdscrz"))))
+      (build-system gnu-build-system)
+      (native-inputs
+       `(("autoconf" ,autoconf-wrapper)
+         ("automake" ,automake)))
+      (inputs `(("perl" ,perl)
+                ("perl-text-template" ,perl-text-template)
+                ("perl-mime-tools" ,perl-mime-tools)
+                ("perl-gnupg-interface" ,perl-gnupg-interface)
+                ("perl-net-idn-encode" ,perl-net-idn-encode)
+                ("libmd" ,libmd)))
+      (arguments
+       `(#:tests? #f
+         #:phases
+         (modify-phases %standard-phases
+           (replace 'configure
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((out (assoc-ref outputs "out")))
+                 (substitute* "keyanalyze/Makefile"
+                   (("LDLIBS") (string-append "CC=" (which "gcc") "\nLDLIBS")))
+                 (substitute* "keyanalyze/Makefile"
+                   (("\\./configure") (string-append "./configure --prefix=" out)))
+                 (substitute* "gpgwrap/Makefile"
+                   (("\\} clean")
+                    (string-append "} clean\ninstall:\n\tinstall -D bin/gpgwrap "
+                                   out "/bin/gpgwrap\n")))
+                 (substitute* '("gpgsigs/Makefile" "keyanalyze/Makefile"
+                                "keylookup/Makefile" "sig2dot/Makefile"
+                                "springgraph/Makefile")
+                   (("/usr") out))
+                 (setenv "CONFIG_SHELL" (which "sh")))))
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys #:rest args)
+               (let ((out (assoc-ref outputs "out"))
+                     (install (assoc-ref %standard-phases 'install)))
+                 (apply install args)
+                 (for-each
+                  (lambda (dir file)
+                    (copy-file (string-append dir "/" file)
+                               (string-append out "/bin/" file)))
+                  '("caff" "caff" "caff" "gpgdir" "gpg-key2ps"
+                    "gpglist" "gpg-mailkeys" "gpgparticipants")
+                  '("caff" "pgp-clean" "pgp-fixkey" "gpgdir" "gpg-key2ps"
+                    "gpglist" "gpg-mailkeys" "gpgparticipants"))
+                 (for-each
+                  (lambda (dir file)
+                    (copy-file (string-append dir "/" file)
+                               (string-append out "/share/man/man1/" file)))
+                  '("caff" "caff" "caff" "gpgdir"
+                    "gpg-key2ps" "gpglist" "gpg-mailkeys"
+                    "gpgparticipants" "gpgsigs" "gpgwrap/doc"
+                    "keyanalyze" "keyanalyze/pgpring" "keyanalyze")
+                  '("caff.1" "pgp-clean.1" "pgp-fixkey.1" "gpgdir.1"
+                    "gpg-key2ps.1" "gpglist.1" "gpg-mailkeys.1"
+                    "gpgparticipants.1" "gpgsigs.1" "gpgwrap.1"
+                    "process_keys.1" "pgpring.1" "keyanalyze.1")))))
+           (add-after 'install 'wrap-programs
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let* ((out (assoc-ref outputs "out")))
+                 (wrap-program
+                     (string-append out "/bin/caff")
+                   `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))))))))
+      (synopsis "Collection of scripts for simplifying gnupg key signing")
+      (description
+       "Signing-party is a collection for all kinds of PGP/GnuPG related things,
 including tools for signing keys, keyring analysis, and party preparation.
 @enumerate
 @item caff: CA - Fire and Forget signs and mails a key
@@ -718,11 +722,10 @@ including tools for signing keys, keyring analysis, and party preparation.
 @item sig2dot: converts a list of GnuPG signatures to a .dot file
 @item springgraph: creates a graph from a .dot file
 @end enumerate")
-   ;; gpl2+ for almost all programs, except for keyanalyze: gpl2
-   ;; and caff and gpgsigs: bsd-3, see
-   ;; http://packages.debian.org/changelogs/pool/main/s/signing-party/current/copyright
-   (license license:gpl2)
-   (home-page "https://pgp-tools.alioth.debian.org/")))
+      ;; gpl2+ for almost all programs, except for keyanalyze: gpl2
+      ;; and caff and gpgsigs: bsd-3, see
+      ;; http://packages.debian.org/changelogs/pool/main/s/signing-party/current/copyright
+      (license license:gpl2))))
 
 (define-public pinentry-tty
   (package